summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2020-12-21 05:28:52 -0800
committerZac Medico <zmedico@gentoo.org>2020-12-21 05:29:29 -0800
commitdaf48fac7f489492cba8a8c6cb04252affff394c (patch)
treeefd93e29fb7f91a4ee3aed2252fe4b38b4062238
parentmail-filter/opendkim: typo fix. (diff)
downloadgentoo-daf48fac7f489492cba8a8c6cb04252affff394c.tar.gz
gentoo-daf48fac7f489492cba8a8c6cb04252affff394c.tar.bz2
gentoo-daf48fac7f489492cba8a8c6cb04252affff394c.zip
app-emulation/s6-overlay: Bump to version 2.1.0.2
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--app-emulation/s6-overlay/Manifest1
-rw-r--r--app-emulation/s6-overlay/s6-overlay-2.1.0.2.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-emulation/s6-overlay/Manifest b/app-emulation/s6-overlay/Manifest
index 10afae83b5a2..4b3eabe8b046 100644
--- a/app-emulation/s6-overlay/Manifest
+++ b/app-emulation/s6-overlay/Manifest
@@ -1 +1,2 @@
DIST s6-overlay-1.18.1.3.tar.gz 20067 BLAKE2B 7006549052fb27c8e7ec2a756854ebd82a41a88e14be45657c375321f4c18f482aefc8d21f1d57d8432ff1b836f114aac75a28b56bdd7722b14de3c06330024d SHA512 2b17b86a93e1efc27181a100bb86aacbce2e2c58cfd0d0855a293b99ba5c871a2f17bd10fa14b173b297816ae2d1658aaee2e6a6e25b957ad60f93d535955775
+DIST s6-overlay-2.1.0.2.tar.gz 30688 BLAKE2B 14d631a23be831d9dbc62a7e5ca341320eb8a0f46ae94d243bba4d6ba8fe9f6102dc818555398af64a207ea3056eb2cbbe045b5ec3baaf7d3a058217ad20e4f7 SHA512 6ff18566c64031fca985b36d6cbba646c3fb5c7f16a9d2dcca74e66ed4de5f10399c2142453e550c4e711f716158b91dd5777c7f6a03a91ed61ca9e81d6cef30
diff --git a/app-emulation/s6-overlay/s6-overlay-2.1.0.2.ebuild b/app-emulation/s6-overlay/s6-overlay-2.1.0.2.ebuild
new file mode 100644
index 000000000000..8ad5f5094731
--- /dev/null
+++ b/app-emulation/s6-overlay/s6-overlay-2.1.0.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/just-containers/${PN}"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/just-containers/${PN}/archive/v${PV}.tar.gz ->
+ ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="an s6-based init system for containers"
+HOMEPAGE="https://github.com/just-containers/s6-overlay"
+
+LICENSE="ISC"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="sys-apps/s6
+ sys-apps/s6-portable-utils"
+
+src_install() {
+ dodoc *.md
+ cd builder/overlay-rootfs
+ dobin usr/bin/{fix-attrs,logutil*,print*,with*}
+
+ insinto /
+ doins -r etc init
+
+ # create must exist directories
+ dodir /etc/{cont-init.d,cont-finish.d,fix-attrs.d,services.d}
+ dodir /etc/s6/init/env-stage2
+
+ # create "supervise" directory in fdholder, its needed for no-catchall
+ # stage2 wake up
+ dodir /etc/s6/services/s6-fdholderd/supervise
+ fperms 0700 /etc/s6/services/s6-fdholderd/supervise
+
+ # fix misc permissions
+ fperms 0755 /init
+ fperms 0755 /etc/s6/init/init-stage1 \
+ /etc/s6/init/init-stage2 \
+ /etc/s6/init/init-stage2-redirfd \
+ /etc/s6/init/init-stage3
+ fperms 0755 /etc/s6/init-catchall/init-stage1 \
+ /etc/s6/init-catchall/init-stage2
+ fperms 0755 /etc/s6/init-no-catchall/init-stage1 \
+ /etc/s6/init-no-catchall/init-stage2
+ fperms 0755 /etc/s6/services/.s6-svscan/crash
+ fperms 0755 /etc/s6/services/.s6-svscan/finish
+ fperms 0755 /etc/s6/services/s6-fdholderd/run
+ fperms 0755 /etc/s6/services/s6-svscan-log/run
+}