summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-23 08:53:45 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-23 08:53:45 +0200
commitdcedde8441339662edf5727b7d3d470dd70d76e8 (patch)
tree13c68c67879bcab5a4d71b61d949e1bae25cf531
parentxfce-extra/xfce4-cpugraph-plugin: Bump to 1.2.8 (diff)
downloadgentoo-dcedde8441339662edf5727b7d3d470dd70d76e8.tar.gz
gentoo-dcedde8441339662edf5727b7d3d470dd70d76e8.tar.bz2
gentoo-dcedde8441339662edf5727b7d3d470dd70d76e8.zip
dev-python/easyprocess: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/easyprocess/Manifest2
-rw-r--r--dev-python/easyprocess/easyprocess-1.1-r1.ebuild16
2 files changed, 13 insertions, 5 deletions
diff --git a/dev-python/easyprocess/Manifest b/dev-python/easyprocess/Manifest
index 060ca08b6c1a..dcee7b0100f4 100644
--- a/dev-python/easyprocess/Manifest
+++ b/dev-python/easyprocess/Manifest
@@ -1 +1 @@
-DIST easyprocess-1.1.tar.gz 13755 BLAKE2B 1d1c0d66e34fbb3ea58736cf4750b5fa48dc6e97d07a568086129fc58ca910d26a383e032dd0030da78235695269da6b7886871e6ef0f0ce7a482275ff2aa0e6 SHA512 fd5d0453cab79bb93806ac0dcef97ba207171c087bc5232f30d6fa210fa479e0dff83bdd7bb5c59d71f65582dcb3dfbf5f25ea2e2ee162d8d5feb8ca8d223a68
+DIST easyprocess-1.1.gh.tar.gz 13755 BLAKE2B 1d1c0d66e34fbb3ea58736cf4750b5fa48dc6e97d07a568086129fc58ca910d26a383e032dd0030da78235695269da6b7886871e6ef0f0ce7a482275ff2aa0e6 SHA512 fd5d0453cab79bb93806ac0dcef97ba207171c087bc5232f30d6fa210fa479e0dff83bdd7bb5c59d71f65582dcb3dfbf5f25ea2e2ee162d8d5feb8ca8d223a68
diff --git a/dev-python/easyprocess/easyprocess-1.1-r1.ebuild b/dev-python/easyprocess/easyprocess-1.1-r1.ebuild
index ef07caf72d06..2dbb1d8a20f1 100644
--- a/dev-python/easyprocess/easyprocess-1.1-r1.ebuild
+++ b/dev-python/easyprocess/easyprocess-1.1-r1.ebuild
@@ -3,13 +3,20 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
+
inherit distutils-r1
DESCRIPTION="Easy to use Python subprocess interface"
-HOMEPAGE="https://github.com/ponty/EasyProcess"
-SRC_URI="https://github.com/ponty/EasyProcess/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="
+ https://github.com/ponty/EasyProcess/
+ https://pypi.org/project/EasyProcess/
+"
+SRC_URI="
+ https://github.com/ponty/EasyProcess/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
S="${WORKDIR}/EasyProcess-${PV}"
LICENSE="BSD-2"
@@ -22,7 +29,8 @@ BDEPEND="
dev-python/pyvirtualdisplay[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
x11-base/xorg-server[xvfb]
- )"
+ )
+"
distutils_enable_tests pytest