summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2016-12-29 23:08:08 +0100
committerMarc Schiffbauer <mschiff@gentoo.org>2016-12-30 19:00:26 +0100
commitdd5dc2301b7bdb901bed9646347eff5e8232c77a (patch)
treefbc1e31ffac68b9c232a7b4f27174f4ecbf661ce
parentsci-geosciences/opencpn-plugin-ocpn_draw: bump version (diff)
downloadgentoo-dd5dc2301b7bdb901bed9646347eff5e8232c77a.tar.gz
gentoo-dd5dc2301b7bdb901bed9646347eff5e8232c77a.tar.bz2
gentoo-dd5dc2301b7bdb901bed9646347eff5e8232c77a.zip
sci-geosciences/opencpn-plugin-route: added new plugin
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--sci-geosciences/opencpn-plugin-route/Manifest1
-rw-r--r--sci-geosciences/opencpn-plugin-route/metadata.xml15
-rw-r--r--sci-geosciences/opencpn-plugin-route/opencpn-plugin-route-1.2.ebuild38
-rw-r--r--sci-geosciences/opencpn-plugin-route/opencpn-plugin-route-9999.ebuild38
4 files changed, 92 insertions, 0 deletions
diff --git a/sci-geosciences/opencpn-plugin-route/Manifest b/sci-geosciences/opencpn-plugin-route/Manifest
new file mode 100644
index 000000000000..826d0664f011
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-route/Manifest
@@ -0,0 +1 @@
+DIST opencpn-plugin-route-1.2.tar.gz 373474 SHA256 e72b08948f0b4adaaca16ce438a450148138b2d95db039553c74f1a33eba44ea SHA512 4dcaa4592f72c6a093276689db5ffa8dae1ed3e0ac6790b85352a6a1942d8863c8f19dfd1110256df9ac28e8056442344852d7790ae97201efe965485a5faa26 WHIRLPOOL fa3a66b18b974718603f8048f7634a43d79d87cddb0f77367dfea3e9379929f2fbd78947b3e7dca50bc15316d1910dc0131b22ebf4265ba5cd20a8ebf99c64e7
diff --git a/sci-geosciences/opencpn-plugin-route/metadata.xml b/sci-geosciences/opencpn-plugin-route/metadata.xml
new file mode 100644
index 000000000000..6e6d546794c3
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-route/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mschiff@gentoo.org</email>
+ <name>Marc Schiffbauer</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-geosciences@gentoo.org</email>
+ <name>Gentoo Geosciences Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">SaltyPaws/route_pi</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-geosciences/opencpn-plugin-route/opencpn-plugin-route-1.2.ebuild b/sci-geosciences/opencpn-plugin-route/opencpn-plugin-route-1.2.ebuild
new file mode 100644
index 000000000000..59b68d6d9ddb
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-route/opencpn-plugin-route-1.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+MY_PN="route_pi"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/SaltyPaws/${MY_PN}.git"
+ inherit git-r3 cmake-utils wxwidgets
+ KEYWORDS=""
+else
+ SRC_URI="
+ https://github.com/SaltyPaws/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ "
+ inherit cmake-utils wxwidgets
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="Route Plotting Plugin for OpenCPN"
+HOMEPAGE="https://github.com/SaltyPaws/DR_pi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=sci-geosciences/opencpn-4.2.0
+ sys-devel/gettext
+"
+DEPEND="${RDEPEND}"
+src_prepare() {
+ need-wxwidgets unicode
+ cmake-utils_src_prepare
+}
diff --git a/sci-geosciences/opencpn-plugin-route/opencpn-plugin-route-9999.ebuild b/sci-geosciences/opencpn-plugin-route/opencpn-plugin-route-9999.ebuild
new file mode 100644
index 000000000000..59b68d6d9ddb
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-route/opencpn-plugin-route-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+MY_PN="route_pi"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/SaltyPaws/${MY_PN}.git"
+ inherit git-r3 cmake-utils wxwidgets
+ KEYWORDS=""
+else
+ SRC_URI="
+ https://github.com/SaltyPaws/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ "
+ inherit cmake-utils wxwidgets
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="Route Plotting Plugin for OpenCPN"
+HOMEPAGE="https://github.com/SaltyPaws/DR_pi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=sci-geosciences/opencpn-4.2.0
+ sys-devel/gettext
+"
+DEPEND="${RDEPEND}"
+src_prepare() {
+ need-wxwidgets unicode
+ cmake-utils_src_prepare
+}