summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-20 04:11:32 +0100
committerSam James <sam@gentoo.org>2022-06-20 04:11:38 +0100
commitde25b99f222003cc373e990ed62f6e5fc55dddc7 (patch)
tree55bdff167216196f3a31dffe2f279ef97d01f83a
parentkde-misc/playbar2: treeclean (diff)
downloadgentoo-de25b99f222003cc373e990ed62f6e5fc55dddc7.tar.gz
gentoo-de25b99f222003cc373e990ed62f6e5fc55dddc7.tar.bz2
gentoo-de25b99f222003cc373e990ed62f6e5fc55dddc7.zip
dev-python/dicttoxml: treeclean
Bug: https://bugs.gentoo.org/846788 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/dicttoxml/Manifest1
-rw-r--r--dev-python/dicttoxml/dicttoxml-1.7.4-r3.ebuild22
-rw-r--r--dev-python/dicttoxml/files/dicttoxml-1.7.4-py3.10.patch58
-rw-r--r--dev-python/dicttoxml/metadata.xml17
-rw-r--r--profiles/package.mask6
5 files changed, 0 insertions, 104 deletions
diff --git a/dev-python/dicttoxml/Manifest b/dev-python/dicttoxml/Manifest
deleted file mode 100644
index 4a7bb4a80d19..000000000000
--- a/dev-python/dicttoxml/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST dicttoxml-1.7.4.tar.gz 18190 BLAKE2B e8fd4974cbd9e83b72c25f28fa5595421be88ed5fbb1e64721280c4ead3003f95c98c7b4f12bced926f0c4af31b30dd76ddd49ddf297fa5f68eeb466d042ede6 SHA512 91abcf2b9b248717618e9fc1c8694e881b9deaa16438dd4674f94a22b4aabfdab3b13f95c3d44a60577d49eca82fb268f59b33d1312cf5388bdaf949a2865cbf
diff --git a/dev-python/dicttoxml/dicttoxml-1.7.4-r3.ebuild b/dev-python/dicttoxml/dicttoxml-1.7.4-r3.ebuild
deleted file mode 100644
index e9afd3ab5d7c..000000000000
--- a/dev-python/dicttoxml/dicttoxml-1.7.4-r3.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Converts a Python dictionary or other data type to a valid XML string"
-HOMEPAGE="https://github.com/quandyfactory/dicttoxml https://pypi.org/project/dicttoxml/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-
-PATCHES=(
- # https://github.com/quandyfactory/dicttoxml/pull/73/files
- "${FILESDIR}/${P}-py3.10.patch"
-)
diff --git a/dev-python/dicttoxml/files/dicttoxml-1.7.4-py3.10.patch b/dev-python/dicttoxml/files/dicttoxml-1.7.4-py3.10.patch
deleted file mode 100644
index 5b3fe172949e..000000000000
--- a/dev-python/dicttoxml/files/dicttoxml-1.7.4-py3.10.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-From 2b7b4522b7255fbc8f1e04304d2e440d333909d5 Mon Sep 17 00:00:00 2001
-From: Kier von Konigslow <kvonkonigslow@gmail.com>
-Date: Sat, 28 Dec 2019 14:08:46 -0500
-Subject: [PATCH] Fix deprecation with collections abc
-
----
- dicttoxml.py | 10 +++++-----
- 1 file changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/dicttoxml.py b/dicttoxml.py
-index ae1384a..5d2dd54 100755
---- a/dicttoxml.py
-+++ b/dicttoxml.py
-@@ -15,7 +15,7 @@
- version = __version__
-
- from random import randint
--import collections
-+import collections.abc
- import numbers
- import logging
- from xml.dom.minidom import parseString
-@@ -96,7 +96,7 @@ def get_xml_type(val):
- return 'null'
- if isinstance(val, dict):
- return 'dict'
-- if isinstance(val, collections.Iterable):
-+ if isinstance(val, collections.abc.Iterable):
- return 'list'
- return type(val).__name__
-
-@@ -188,7 +188,7 @@ def convert(obj, ids, attr_type, item_func, cdata, parent='root'):
- if isinstance(obj, dict):
- return convert_dict(obj, ids, parent, attr_type, item_func, cdata)
-
-- if isinstance(obj, collections.Iterable):
-+ if isinstance(obj, collections.abc.Iterable):
- return convert_list(obj, ids, parent, attr_type, item_func, cdata)
-
- raise TypeError('Unsupported data type: %s (%s)' % (obj, type(obj).__name__))
-@@ -232,7 +232,7 @@ def convert_dict(obj, ids, parent, attr_type, item_func, cdata):
- )
- )
-
-- elif isinstance(val, collections.Iterable):
-+ elif isinstance(val, collections.abc.Iterable):
- if attr_type:
- attr['type'] = get_xml_type(val)
- addline('<%s%s>%s</%s>' % (
-@@ -295,7 +295,7 @@ def convert_list(items, ids, parent, attr_type, item_func, cdata):
- )
- )
-
-- elif isinstance(item, collections.Iterable):
-+ elif isinstance(item, collections.abc.Iterable):
- if not attr_type:
- addline('<%s %s>%s</%s>' % (
- item_name, make_attrstring(attr),
diff --git a/dev-python/dicttoxml/metadata.xml b/dev-python/dicttoxml/metadata.xml
deleted file mode 100644
index 7834b72e5bb3..000000000000
--- a/dev-python/dicttoxml/metadata.xml
+++ /dev/null
@@ -1,17 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>chutzpah@gentoo.org</email>
- <name>Patrick McLean</name>
- </maintainer>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <stabilize-allarches/>
- <upstream>
- <remote-id type="pypi">dicttoxml</remote-id>
- <remote-id type="github">quandyfactory/dicttoxml</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index b1cef337e0af..db6ce509e689 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -295,12 +295,6 @@ dev-python/fusepy
# does not yet support Python 3.10+. Removal on 2022-06-21. bugs #845720, #797850.
dev-python/drf-yasg
-# Michał Górny <mgorny@gentoo.org> (2022-05-21)
-# No commit activity since 2016. Requires patching for Python 3.10.
-# No tests. No revdeps.
-# Removal on 2022-06-20. Bug #846788.
-dev-python/dicttoxml
-
# Hans de Graaff <graaff@gentoo.org> (2022-05-20)
# Unused slots of cucumber components that are no longer or were never
# used by current cucumber versions. Masked for removal in 30 days.