summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-10 16:21:05 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-10 18:01:39 +0200
commitded2915b026612cf3dc282b51d643a029f23e4b6 (patch)
tree4e6fe0ff3f676848a9f1f0a6a9dea13a0f44edb7
parentdev-ros/rqt_gui: Bump to 0.5.2. (diff)
downloadgentoo-ded2915b026612cf3dc282b51d643a029f23e4b6.tar.gz
gentoo-ded2915b026612cf3dc282b51d643a029f23e4b6.tar.bz2
gentoo-ded2915b026612cf3dc282b51d643a029f23e4b6.zip
dev-ros/rqt_gui_cpp: Bump to 0.5.2.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-ros/rqt_gui_cpp/Manifest1
-rw-r--r--dev-ros/rqt_gui_cpp/rqt_gui_cpp-0.5.2.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/rqt_gui_cpp/Manifest b/dev-ros/rqt_gui_cpp/Manifest
index 8675d41dab83..d37ef75b75e0 100644
--- a/dev-ros/rqt_gui_cpp/Manifest
+++ b/dev-ros/rqt_gui_cpp/Manifest
@@ -1 +1,2 @@
DIST rqt-0.5.0.tar.gz 120992 BLAKE2B 645d53ec7070fc5a40760bedc556328e26a16dea7b2990ad0512bc372cb346d545dbea42689b4c39039f17abc4920d5059e5b9a25ac7b77f8b5e5cc02100c5ac SHA512 5c91fe9bce5a7cb0cdc54b42667488d30c33bd57afd30cc8f2047b91b7aa7b8afd936090bfc76be5dbc8c6497623c1be4340e061503f5a65bc94faaad810597e
+DIST rqt-0.5.2.tar.gz 121619 BLAKE2B a065501ee6f78b3e2867aa9a6fc416b70472a3dcd3bf447ab7c07941284add7fdaffafa4bc370ce73b777b9616544a6650bb94c30fb61bed8ce6381a2d88b5cd SHA512 09093e80daefd530b36c1ef90a350c0c5fa7ba4211b779da38c230df445170e766a737cfadec29997f81968c454daec2ffc2b6cf236e41daa21d9536f498fc17
diff --git a/dev-ros/rqt_gui_cpp/rqt_gui_cpp-0.5.2.ebuild b/dev-ros/rqt_gui_cpp/rqt_gui_cpp-0.5.2.ebuild
new file mode 100644
index 000000000000..b6198c787b3d
--- /dev/null
+++ b/dev-ros/rqt_gui_cpp/rqt_gui_cpp-0.5.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/rqt"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Enables GUI plugins to use the C++ client library for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtwidgets:5
+ dev-qt/qtcore:5
+ >=dev-ros/qt_gui_cpp-0.3.0
+ >=dev-ros/qt_gui-0.3.0
+ dev-ros/roscpp
+ dev-ros/nodelet
+ dev-libs/tinyxml2:=
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"