summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-01 19:13:45 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-01 19:16:16 +0200
commitdf22d5e2f561db09570b1a03b4f3e20c73d75ceb (patch)
tree727e74a4e291ac9959b8da3deb9ad3177803bdff
parentdev-python/linkify-it-py: Stabilize 2.0.2 ALLARCHES, #907653 (diff)
downloadgentoo-df22d5e2f561db09570b1a03b4f3e20c73d75ceb.tar.gz
gentoo-df22d5e2f561db09570b1a03b4f3e20c73d75ceb.tar.bz2
gentoo-df22d5e2f561db09570b1a03b4f3e20c73d75ceb.zip
dev-python/krb5: Backport cython-3 fix
Closes: https://bugs.gentoo.org/898686 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/krb5/files/krb5-0.5.0-cython-3.patch26
-rw-r--r--dev-python/krb5/krb5-0.5.0.ebuild5
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/krb5/files/krb5-0.5.0-cython-3.patch b/dev-python/krb5/files/krb5-0.5.0-cython-3.patch
new file mode 100644
index 000000000000..6d9d34dad659
--- /dev/null
+++ b/dev-python/krb5/files/krb5-0.5.0-cython-3.patch
@@ -0,0 +1,26 @@
+From 0e843062ac3916ee0a36f59ba53caabba64cb062 Mon Sep 17 00:00:00 2001
+From: Matus Valo <matusvalo@gmail.com>
+Date: Wed, 15 Mar 2023 21:02:10 +0100
+Subject: [PATCH] Declare the function as noexcept when it is not raising
+ exception.
+
+Cython 3 will require noexcept keyword in the declaraction of the function not raising
+an exceptions.
+---
+ pyproject.toml | 2 +-
+ src/krb5/_creds.pyx | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/krb5/_creds.pyx b/src/krb5/_creds.pyx
+index a4a8a33..5b550e6 100644
+--- a/src/krb5/_creds.pyx
++++ b/src/krb5/_creds.pyx
+@@ -263,7 +263,7 @@ cdef krb5_error_code prompt_callback(
+ const char *banner,
+ int num_prompts,
+ krb5_prompt *prompts,
+-) with gil:
++) noexcept with gil:
+ try:
+ prompter = <Krb5Prompt>data
+
diff --git a/dev-python/krb5/krb5-0.5.0.ebuild b/dev-python/krb5/krb5-0.5.0.ebuild
index 4a3bacb22774..5c04cef7755f 100644
--- a/dev-python/krb5/krb5-0.5.0.ebuild
+++ b/dev-python/krb5/krb5-0.5.0.ebuild
@@ -30,3 +30,8 @@ BDEPEND="
"
distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/jborean93/pykrb5/pull/27
+ "${FILESDIR}/${P}-cython-3.patch"
+)