summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-14 23:21:58 +0100
committerSam James <sam@gentoo.org>2022-09-14 23:23:16 +0100
commite083dfe996e01a289205e104a32925a861b44be0 (patch)
tree832c77fb7c6e72693bf800ead7b23f6ffcd3f0c2
parentgames-action/swordandsworcery: fix FLAC dep (diff)
downloadgentoo-e083dfe996e01a289205e104a32925a861b44be0.tar.gz
gentoo-e083dfe996e01a289205e104a32925a861b44be0.tar.bz2
gentoo-e083dfe996e01a289205e104a32925a861b44be0.zip
media-libs/audiofile: fix tests
They need to be linked statically. Not poking further at this, upstream inactive since 2016. Was broken by EAPI 7->8. Closes: https://bugs.gentoo.org/869677 Fixes: f20436cb65a32bdd1be7d589485507873427f78a Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-libs/audiofile/audiofile-0.3.6-r4.ebuild55
-rw-r--r--media-libs/audiofile/audiofile-0.3.6-r5.ebuild2
2 files changed, 57 insertions, 0 deletions
diff --git a/media-libs/audiofile/audiofile-0.3.6-r4.ebuild b/media-libs/audiofile/audiofile-0.3.6-r4.ebuild
new file mode 100644
index 000000000000..6c7e04198274
--- /dev/null
+++ b/media-libs/audiofile/audiofile-0.3.6-r4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools gnome.org multilib-minimal
+
+DESCRIPTION="An elegant API for accessing audio files"
+HOMEPAGE="https://audiofile.68k.org/"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0/1" # subslot = soname major version
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
+IUSE="flac"
+
+RDEPEND="flac? ( >=media-libs/flac-1.2.1[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3.6-gcc6-build-fixes.patch
+ "${FILESDIR}"/${PN}-0.3.6-CVE-2015-7747.patch
+ "${FILESDIR}"/${PN}-0.3.6-mingw32.patch
+ "${FILESDIR}"/${PN}-0.3.6-CVE-2017-68xx.patch
+ "${FILESDIR}"/${PN}-0.3.6-CVE-2018-13440-CVE-2018-17095.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ # Tests depend on statically compiled binaries to work, so we'll have to
+ # delete them later rather than not compile them at all
+ local myconf=(
+ --enable-largefile
+ --disable-werror
+ --disable-examples
+ $(use_enable flac)
+ )
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+}
+
+multilib_src_test() {
+ emake check
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ # package provides .pc file
+ find "${ED}" -name '*.la' -delete || die
+ find "${ED}" -name '*.a' -delete || die
+}
diff --git a/media-libs/audiofile/audiofile-0.3.6-r5.ebuild b/media-libs/audiofile/audiofile-0.3.6-r5.ebuild
index 2e9e462ef23b..02f89e0f9b41 100644
--- a/media-libs/audiofile/audiofile-0.3.6-r5.ebuild
+++ b/media-libs/audiofile/audiofile-0.3.6-r5.ebuild
@@ -35,6 +35,8 @@ multilib_src_configure() {
# delete them later rather than not compile them at all
local myconf=(
--enable-largefile
+ # static needed for tests, bug #869677
+ --enable-static
--disable-werror
--disable-examples
$(use_enable flac)