summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2023-01-24 18:01:12 +0100
committerJakov Smolić <jsmolic@gentoo.org>2023-01-24 21:12:21 +0100
commite0954c3e4fe7ac7102b087f23939ce0574b7ad6f (patch)
tree8c7c822aabf55fd4dde00c1dac2b3cec2c2ed4f9
parentdev-ros/ament_cmake_python: treeclean (diff)
downloadgentoo-e0954c3e4fe7ac7102b087f23939ce0574b7ad6f.tar.gz
gentoo-e0954c3e4fe7ac7102b087f23939ce0574b7ad6f.tar.bz2
gentoo-e0954c3e4fe7ac7102b087f23939ce0574b7ad6f.zip
dev-ros/ament_cmake_ros: treeclean
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--dev-ros/ament_cmake_ros/Manifest1
-rw-r--r--dev-ros/ament_cmake_ros/ament_cmake_ros-0.10.0.ebuild46
-rw-r--r--dev-ros/ament_cmake_ros/ament_cmake_ros-9999.ebuild46
-rw-r--r--dev-ros/ament_cmake_ros/metadata.xml11
4 files changed, 0 insertions, 104 deletions
diff --git a/dev-ros/ament_cmake_ros/Manifest b/dev-ros/ament_cmake_ros/Manifest
deleted file mode 100644
index 7f6cc5f2cccf..000000000000
--- a/dev-ros/ament_cmake_ros/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST ament_cmake_ros-0.10.0.tar.gz 10411 BLAKE2B 8113da7c8dc04339b0c1a5aff89cc9e1eb0dcf453101fb9e65c0c95fc6275a3049f83c93ff83106d22dee20d6aa6b190a49b02a51336a3858db88cf3a39bce95 SHA512 1feaab1c1100587eec42bfd62a53baaa802d7de1c8d14e991615ab60b97a9350d268f9387998d2c05ee2742886a0b5805c3053eef6b517323e24fddfe5b7d4e8
diff --git a/dev-ros/ament_cmake_ros/ament_cmake_ros-0.10.0.ebuild b/dev-ros/ament_cmake_ros/ament_cmake_ros-0.10.0.ebuild
deleted file mode 100644
index 7493e17e73e0..000000000000
--- a/dev-ros/ament_cmake_ros/ament_cmake_ros-0.10.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 2019-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit cmake python-any-r1
-
-ROS_PN="ament_cmake_ros"
-if [ "${PV#9999}" != "${PV}" ] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ros2/ament_cmake_ros"
- S="${WORKDIR}/${P}/${PN}"
-else
- SRC_URI="https://github.com/ros2/ament_cmake_ros/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
- S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
- KEYWORDS="~amd64"
-fi
-
-DESCRIPTION="ROS specific CMake bits in the ament buildsystem"
-HOMEPAGE="https://github.com/ros2/ament_cmake_ros"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- $(python_gen_any_dep 'ros-meta/ament_cmake[${PYTHON_USEDEP}]')
- test? (
- dev-ros/ament_lint_auto
- )
- ${PYTHON_DEPS}
-"
-
-python_check_deps() {
- python_has_version "ros-meta/ament_cmake[${PYTHON_USEDEP}]"
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_TESTING=$(usex test ON OFF)
- )
- cmake_src_configure
-}
diff --git a/dev-ros/ament_cmake_ros/ament_cmake_ros-9999.ebuild b/dev-ros/ament_cmake_ros/ament_cmake_ros-9999.ebuild
deleted file mode 100644
index 7493e17e73e0..000000000000
--- a/dev-ros/ament_cmake_ros/ament_cmake_ros-9999.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 2019-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit cmake python-any-r1
-
-ROS_PN="ament_cmake_ros"
-if [ "${PV#9999}" != "${PV}" ] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ros2/ament_cmake_ros"
- S="${WORKDIR}/${P}/${PN}"
-else
- SRC_URI="https://github.com/ros2/ament_cmake_ros/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
- S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
- KEYWORDS="~amd64"
-fi
-
-DESCRIPTION="ROS specific CMake bits in the ament buildsystem"
-HOMEPAGE="https://github.com/ros2/ament_cmake_ros"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- $(python_gen_any_dep 'ros-meta/ament_cmake[${PYTHON_USEDEP}]')
- test? (
- dev-ros/ament_lint_auto
- )
- ${PYTHON_DEPS}
-"
-
-python_check_deps() {
- python_has_version "ros-meta/ament_cmake[${PYTHON_USEDEP}]"
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_TESTING=$(usex test ON OFF)
- )
- cmake_src_configure
-}
diff --git a/dev-ros/ament_cmake_ros/metadata.xml b/dev-ros/ament_cmake_ros/metadata.xml
deleted file mode 100644
index cba09cedb988..000000000000
--- a/dev-ros/ament_cmake_ros/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>ros@gentoo.org</email>
- <name>Gentoo ROS Project</name>
- </maintainer>
- <upstream>
- <remote-id type="github">ros2/ament_cmake_ros</remote-id>
- </upstream>
-</pkgmetadata>