summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-11-21 00:55:51 +0100
committerDavid Seifert <soap@gentoo.org>2022-11-21 00:55:51 +0100
commite0b7668889d663e53fb4baa5aa8074a56c8be10f (patch)
treee8ab3929ef8d05fa22be0e0dfa3d8236ddcded30
parentapp-text/pspresent: update EAPI 6 -> 8 (diff)
downloadgentoo-e0b7668889d663e53fb4baa5aa8074a56c8be10f.tar.gz
gentoo-e0b7668889d663e53fb4baa5aa8074a56c8be10f.tar.bz2
gentoo-e0b7668889d663e53fb4baa5aa8074a56c8be10f.zip
app-text/odt2txt: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--app-text/odt2txt/files/odt2txt-0.5-darwin_iconv.patch14
-rw-r--r--app-text/odt2txt/files/odt2txt-0.5-makefile.patch116
-rw-r--r--app-text/odt2txt/odt2txt-0.5-r1.ebuild (renamed from app-text/odt2txt/odt2txt-0.5.ebuild)24
3 files changed, 127 insertions, 27 deletions
diff --git a/app-text/odt2txt/files/odt2txt-0.5-darwin_iconv.patch b/app-text/odt2txt/files/odt2txt-0.5-darwin_iconv.patch
deleted file mode 100644
index 05957269888e..000000000000
--- a/app-text/odt2txt/files/odt2txt-0.5-darwin_iconv.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -ur odt2txt-0.4/Makefile odt2txt-0.4/Makefile
---- odt2txt-0.4/Makefile 2008-06-23 23:32:28 +0400
-+++ odt2txt-0.4/Makefile 2010-05-24 15:39:16 +0400
-@@ -56,6 +56,9 @@
- CFLAGS += -I$(ZLIB_DIR)
- LIBS = $(ZLIB_DIR)/libz.a
- endif
-+ifeq ($(UNAME_S),Darwin)
-+ LIBS += -liconv
-+endif
- ifeq ($(UNAME_O),Cygwin)
- CFLAGS += -DICONV_CHAR="const char"
- LIBS += -liconv
-
diff --git a/app-text/odt2txt/files/odt2txt-0.5-makefile.patch b/app-text/odt2txt/files/odt2txt-0.5-makefile.patch
new file mode 100644
index 000000000000..b87814f3ff58
--- /dev/null
+++ b/app-text/odt2txt/files/odt2txt-0.5-makefile.patch
@@ -0,0 +1,116 @@
+--- a/Makefile
++++ b/Makefile
+@@ -2,28 +2,22 @@
+ UNAME_S := $(shell uname -s 2>/dev/null || echo unknown)
+ UNAME_O := $(shell uname -o 2>/dev/null || echo unknown)
+
+-ifdef DEBUG
+-CFLAGS = -O0 -g -Wextra -DMEMDEBUG -DSTRBUF_CHECK
+-#LDFLAGS = -lefence
+-LDFLAGS += -g
+-else
+-CFLAGS = -O2
+-endif
+-
+ ifdef NO_ICONV
+-CFLAGS += -DNO_ICONV
++CPPFLAGS += -DNO_ICONV
+ endif
+
+-LIBS = -lz
++CPPFLAGS += $(shell $(PKG_CONFIG) --cflags zlib)
++LDLIBS += $(shell $(PKG_CONFIG) --libs zlib)
++
+ ZIP_OBJS =
+ ifdef HAVE_LIBZIP
+- CFLAGS += -DHAVE_LIBZIP
+- LIBS += -lzip
++ CPPFLAGS += -DHAVE_LIBZIP
++ LDLIBS += -lzip
+ else
+ ZIP_OBJS = kunzip/fileio.o kunzip/zipfile.o
+ endif
+
+-OBJ = odt2txt.o regex.o mem.o strbuf.o $(ZIP_OBJS)
++OBJ = regex.o mem.o strbuf.o $(ZIP_OBJS)
+ TEST_OBJ = t/test-strbuf.o t/test-regex.o
+ ALL_OBJ = $(OBJ) $(TEST_OBJ)
+
+@@ -37,50 +31,44 @@
+ MAN1DIR = $(MANDIR)/man1
+
+ ifeq ($(UNAME_S),FreeBSD)
+- CFLAGS += -DICONV_CHAR="const char" -I/usr/local/include
++ CPPFLAGS += -DICONV_CHAR="const char"
+ LDFLAGS += -L/usr/local/lib
+- LIBS += -liconv
++ LDLIBS += -liconv
+ endif
+ ifeq ($(UNAME_S),OpenBSD)
+- CFLAGS += -DICONV_CHAR="const char" -I/usr/local/include
++ CPPFLAGS += -DICONV_CHAR="const char"
+ LDFLAGS += -L/usr/local/lib
+- LIBS += -liconv
++ LDLIBS += -liconv
+ endif
+ ifeq ($(UNAME_S),Darwin)
+- CFLAGS += -I/opt/local/include
+- LDFLAGS += -L/opt/local/lib
+- LIBS += -liconv
++ LDLIBS += -liconv
+ endif
+ ifeq ($(UNAME_S),NetBSD)
+- CFLAGS += -DICONV_CHAR="const char"
++ CPPFLAGS += -DICONV_CHAR="const char"
+ endif
+ ifeq ($(UNAME_S),SunOS)
+- ifeq ($(CC),cc)
+- ifdef DEBUG
+- CFLAGS = -v -g -DMEMDEBUG -DSTRBUF_CHECK
+- else
+- CFLAGS = -xO3
+- endif
+- endif
+- CFLAGS += -DICONV_CHAR="const char"
++ CPPFLAGS += -DICONV_CHAR="const char"
+ endif
+ ifeq ($(UNAME_S),HP-UX)
+- CFLAGS += -I$(ZLIB_DIR)
+- LIBS = $(ZLIB_DIR)/libz.a
++ CPPFLAGS += -I$(ZLIB_DIR)
++ LDLIBS += $(ZLIB_DIR)/libz.a
++endif
++ifeq ($(UNAME_S),Darwin)
++ LDLIBS += -liconv
+ endif
+ ifeq ($(UNAME_O),Cygwin)
+- CFLAGS += -DICONV_CHAR="const char"
+- LIBS += -liconv
++ CPPFLAGS += -DICONV_CHAR="const char"
++ LDLIBS += -liconv
+ EXT = .exe
+ endif
+ ifneq ($(MINGW32),)
+- CFLAGS += -DICONV_CHAR="const char" -I$(REGEX_DIR) -I$(ZLIB_DIR)
+- LIBS = $(REGEX_DIR)/regex.o
++ CPPFLAGS += -DICONV_CHAR="const char" -I$(REGEX_DIR) -I$(ZLIB_DIR)
++ LDLIBS += $(REGEX_DIR)/regex.o
+ ifdef STATIC
+- LIBS += $(wildcard $(ICONV_DIR)/lib/.libs/*.o)
+- LIBS += $(ZLIB_DIR)/zlib.a
++ LDLIBS += $(wildcard $(ICONV_DIR)/lib/.libs/*.o)
++ LDLIBS += $(ZLIB_DIR)/zlib.a
+ else
+- LIBS += -liconv
++ LDLIBS += -liconv
+ endif
+ EXT = .exe
+ endif
+@@ -89,7 +77,6 @@
+ MAN = odt2txt.1
+
+ $(BIN): $(OBJ)
+- $(CC) -o $@ $(LDFLAGS) $(OBJ) $(LIBS)
+
+ t/test-strbuf: t/test-strbuf.o strbuf.o mem.o
+ t/test-regex: t/test-regex.o regex.o strbuf.o mem.o
diff --git a/app-text/odt2txt/odt2txt-0.5.ebuild b/app-text/odt2txt/odt2txt-0.5-r1.ebuild
index e736a365e9a1..70a3b4a55b3e 100644
--- a/app-text/odt2txt/odt2txt-0.5.ebuild
+++ b/app-text/odt2txt/odt2txt-0.5-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs
@@ -12,23 +12,21 @@ SRC_URI="https://github.com/dstosberg/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ppc64 ~sparc x86"
-IUSE=""
RDEPEND="
!app-office/unoconv
sys-libs/zlib
- virtual/libiconv
-"
-DEPEND="${RDEPEND}
- sys-apps/groff
-"
-PATCHES="${FILESDIR}/${P}-darwin_iconv.patch"
-
-src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+ virtual/libiconv"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-apps/groff"
+
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+
+src_configure() {
+ tc-export CC PKG_CONFIG
}
src_install() {
- emake install DESTDIR="${D}" PREFIX=/usr
+ emake install DESTDIR="${D}" PREFIX="${EPREFIX}"/usr
doman odt2txt.1
}