summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-12-24 16:42:18 +0100
committerManuel Rüger <mrueg@gentoo.org>2015-12-24 16:42:18 +0100
commite0c9db08c6ce1a76120fbbc7340187163b5e1b4d (patch)
tree84958aa29fbc3c4a823bc81f842a81d8b980f232
parentprofiles: Mask media-tv/xawtv for removal (diff)
downloadgentoo-e0c9db08c6ce1a76120fbbc7340187163b5e1b4d.tar.gz
gentoo-e0c9db08c6ce1a76120fbbc7340187163b5e1b4d.tar.bz2
gentoo-e0c9db08c6ce1a76120fbbc7340187163b5e1b4d.zip
dev-libs/libinput: Version bump
Package-Manager: portage-2.2.26
-rw-r--r--dev-libs/libinput/Manifest1
-rw-r--r--dev-libs/libinput/libinput-1.1.4.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index 216da5971aa2..cf1b63da0874 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -4,3 +4,4 @@ DIST libinput-1.1.0.tar.xz 802348 SHA256 673186ea2a0d2b695afaa9758834f9217b17577
DIST libinput-1.1.1.tar.xz 791276 SHA256 2de2b433ddc73ba1bfd4d309fd873d0ced6937cf1a7a94e4afbf18ddd8f8dd17 SHA512 3806e67a4530be71463b693076a64f210475d3487abc2848f5ee13b92b281c6e4950bdb754c6b9c090c51c5b8dd4e698b882ae325bdea78bb05e6b7399eb75f0 WHIRLPOOL 031af4cb17d51d2f888cdb3192ccb25e4b3eb22422aeda3e999fd215b3d5bba89782b1f4a5e0b95706bf6da2ffaf3cbc0b5078a1fa95433afd414b79826542de
DIST libinput-1.1.2.tar.xz 818680 SHA256 a323a32718a8f0f5e85e1ed3a81f0dde45eb52b215a15c7887bec40961d97a84 SHA512 7babc1be1ad08915fb9cf361c99d9c91eea74cfd67cc5b7608f53dbcec8ed986cd9844e6a555a88c52687e7660a20ed3ff9342aba206125d7d4ba40019bb2127 WHIRLPOOL 472ad01b4dae48882e0edbe5bac727084f3e9c8d7fd5138d99b751e08f73cc5f390d091039f60ddd2e2187aaab72020fc15e392fbde16338cc67415512274b6d
DIST libinput-1.1.3.tar.xz 815840 SHA256 b95af39391e2b91957af0addce691a4070b28aff69cd2348823bf6ce8169995e SHA512 ee51b6d005bacca57c4cad5a8b70097990299bf934cb460016176630009cea872e5413e053b09b456d35e085268a9a96ceb667ef0f4cd3b874e89cda2bb1c344 WHIRLPOOL 2934b26ef372f337873eefc5fd0c3464e8d380fc263a6cd0fda759fa5d1efe974dd3a83e076aec0ee2e85259784452c7294b163f8ca657af9c2c803c69540867
+DIST libinput-1.1.4.tar.xz 819536 SHA256 302cb76209b9c57a5a318e178f9bc446eede8ea79386103b5291cbfaa5fab5b6 SHA512 54c1ca1cbb747d62950f5f5bf6a906cdb6b0e79305ba9d7e8408828691eb523be517bb88e739c6ab5465ec95b69c81f096fe8ad4b6bbbd010d431e72d79d0763 WHIRLPOOL 82b9831bce546d4d1329fbf51f64bfea8a1d23bee11cf1664212ba7949e18bff6ae471e2e248f8ec16dc93d8514024a5576fb2a298edea433899c2a69189d6b8
diff --git a/dev-libs/libinput/libinput-1.1.4.ebuild b/dev-libs/libinput/libinput-1.1.4.ebuild
new file mode 100644
index 000000000000..26877357fe85
--- /dev/null
+++ b/dev-libs/libinput/libinput-1.1.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/libinput/"
+SRC_URI="http://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+# Tests require write access to udev rules directory which is a no-no for live system.
+# Other tests are just about logs, exported symbols and autotest of the test library.
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-libs/libevdev-0.4
+ >=sys-libs/mtdev-1.1
+ virtual/libudev
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+# test? (
+# >=dev-libs/check-0.9.10
+# dev-util/valgrind
+# sys-libs/libunwind )
+
+src_configure() {
+ # Doc handling in kinda strange but everything
+ # is available in the tarball already.
+ sed -e 's/^\(SUBDIRS =.*\)doc\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die
+}
+
+src_configure() {
+ # gui can be built but will not be installed
+ # building documentation silently fails with graphviz syntax errors
+ econf \
+ --disable-documentation \
+ --disable-event-gui \
+ $(use_enable test tests) \
+ --with-udev-dir="$(get_udevdir)"
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc -r doc/html
+ prune_libtool_files
+}