summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-03-02 09:58:57 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-02 10:05:42 +0100
commite1ea268f3df4d1b7cf436b077cbd9d5ebeaf2bf9 (patch)
tree7adbd37443f74de2c3acc53343c5ae95aca821f4
parentsci-visualization/gwyddion: Remove old (diff)
downloadgentoo-e1ea268f3df4d1b7cf436b077cbd9d5ebeaf2bf9.tar.gz
gentoo-e1ea268f3df4d1b7cf436b077cbd9d5ebeaf2bf9.tar.bz2
gentoo-e1ea268f3df4d1b7cf436b077cbd9d5ebeaf2bf9.zip
sci-libs/armadillo: Remove old
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Closes: https://github.com/gentoo/gentoo/pull/19731 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sci-libs/armadillo/Manifest2
-rw-r--r--sci-libs/armadillo/armadillo-8.300.2.ebuild144
-rw-r--r--sci-libs/armadillo/armadillo-9.850.1.ebuild148
-rw-r--r--sci-libs/armadillo/metadata.xml40
4 files changed, 18 insertions, 316 deletions
diff --git a/sci-libs/armadillo/Manifest b/sci-libs/armadillo/Manifest
index d603294cedd1..0eacdd62daba 100644
--- a/sci-libs/armadillo/Manifest
+++ b/sci-libs/armadillo/Manifest
@@ -1,3 +1 @@
DIST armadillo-10.2.0.tar.xz 6042348 BLAKE2B e85f24ca7137c3a8c8fc53db15b382f2e4d468673c99e036ef9b4a4436be47d24a37664dfa88ff9effa08a4c868bd212d03c204dda09cd26038a0f8ccbf61375 SHA512 c5d6f4bac0acba63fbd7681653d521249fd303ffbbc5b18df71500eb111514c1d09db600a580091d6a23c83748c109c30938bbcd80a3a0b2c25e2fdea932f2cd
-DIST armadillo-8.300.2.tar.xz 4593916 BLAKE2B 0cb9082d9452b43599dea810036a1cdcd8ef4ab6ce5b2bc7b9d9201f1f396666a2aecb81ffa62388e1ee3de9a8c7df083df594224af47e5df7ee4d3c2743d6cc SHA512 df069634db377e95e02dfca02312b082b34cab91bae0b1fd04a97339477074fc50c74f8adf92786ac6f0fc148044d527461617f382cc996523251b6d1287e41c
-DIST armadillo-9.850.1.tar.xz 4715832 BLAKE2B 41256d8f54ec1f2d4f7cfdf58bd67e66cc2ffbe0f1daf259a4d76e0816d89708fa5528d57b244000393404108c8d0d613d03321f14e5653163d0c1cc6ec7e273 SHA512 b2b9f0290f8f39a687db71a02b127086d5ff22cee77fba5211da2ea8a8d8a5edc256b31b7fce8e98aa1955a84c63e488adcd22f8cd070015a6fcd4b4f1cb37c7
diff --git a/sci-libs/armadillo/armadillo-8.300.2.ebuild b/sci-libs/armadillo/armadillo-8.300.2.ebuild
deleted file mode 100644
index 1ff6d1fd7a2c..000000000000
--- a/sci-libs/armadillo/armadillo-8.300.2.ebuild
+++ /dev/null
@@ -1,144 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-CMAKE_IN_SOURCE_BUILD=1
-
-inherit cmake-utils toolchain-funcs multilib eutils
-
-DESCRIPTION="Streamlined C++ linear algebra library"
-HOMEPAGE="http://arma.sourceforge.net/"
-SRC_URI="mirror://sourceforge/arma/${P}.tar.xz"
-
-LICENSE="Apache-2.0"
-SLOT="0/8"
-KEYWORDS="amd64 ~arm ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="arpack blas debug doc examples hdf5 lapack mkl superlu tbb test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="test? ( lapack )"
-
-# atlas? ( sci-libs/atlas[lapack] )
-
-RDEPEND="
- dev-libs/boost
- arpack? ( sci-libs/arpack )
- blas? ( virtual/blas )
- lapack? ( virtual/lapack )
- superlu? ( >=sci-libs/superlu-5.2 )
-"
-
-DEPEND="${RDEPEND}
- arpack? ( virtual/pkgconfig )
- blas? ( virtual/pkgconfig )
- hdf5? ( sci-libs/hdf5 )
- lapack? ( virtual/pkgconfig )
- mkl? ( sci-libs/mkl )
- tbb? ( dev-cpp/tbb )"
-PDEPEND="${RDEPEND}
- hdf5? ( sci-libs/hdf5 )
- mkl? ( sci-libs/mkl )
- tbb? ( dev-cpp/tbb )"
-
-src_prepare() {
- # avoid the automagic cmake macros
- sed -i -e '/ARMA_Find/d' CMakeLists.txt || die
- cmake-utils_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DINSTALL_LIB_DIR="${EPREFIX}/usr/$(get_libdir)"
- -DARMA_EXTRA_DEBUG="$(usex debug)"
- -DARMA_USE_MKL_ALLOC="$(usex mkl)"
- -DARMA_USE_TBB_ALLOC="$(usex tbb)"
- )
- if use arpack; then
- mycmakeargs+=(
- -DARPACK_FOUND=ON
- -DARPACK_LIBRARY="$($(tc-getPKG_CONFIG) --libs arpack)"
- )
- else
- mycmakeargs+=(
- -DARPACK_FOUND=OFF
- )
- fi
-# if use atlas; then
-# local c=atlas-cblas l=atlas-clapack
-# $(tc-getPKG_CONFIG) --exists ${c}-threads && c+=-threads
-# $(tc-getPKG_CONFIG) --exists ${l}-threads && l+=-threads
-# mycmakeargs+=(
-# -DCBLAS_FOUND=ON
-# -DCBLAS_INCLUDE_DIR="$($(tc-getPKG_CONFIG) --cflags-only-I ${c} | sed 's/-I//')"
-# -DCBLAS_LIBRARIES="$($(tc-getPKG_CONFIG) --libs ${c})"
-# -DCLAPACK_FOUND=ON
-# -DCLAPACK_INCLUDE_DIR="$($(tc-getPKG_CONFIG) --cflags-only-I ${l} | sed 's/-I//')"
-# -DCLAPACK_LIBRARIES="$($(tc-getPKG_CONFIG) --libs ${l})"
-# )
-# fi
- if use blas; then
- mycmakeargs+=(
- -DBLAS_FOUND=ON
- -DBLAS_LIBRARIES="$($(tc-getPKG_CONFIG) --libs blas)"
- )
- else
- mycmakeargs+=(
- -DBLAS_FOUND=OFF
- )
- fi
- if use hdf5; then
- mycmakeargs+=(
- -DHDF5_FOUND=ON
- -DHDF5_LIBRARIES="-lhdf5"
- )
- else
- mycmakeargs+=(
- -DHDF5_FOUND=OFF
- )
- fi
- if use lapack; then
- mycmakeargs+=(
- -DLAPACK_FOUND=ON
- -DLAPACK_LIBRARIES="$($(tc-getPKG_CONFIG) --libs lapack)"
- )
- else
- mycmakeargs+=(
- -DLAPACK_FOUND=OFF
- )
- fi
- if use superlu; then
- mycmakeargs+=(
- -DSuperLU_FOUND=ON
- -DSuperLU_LIBRARY="$($(tc-getPKG_CONFIG) --libs superlu)"
- -DSuperLU_INCLUDE_DIR="$($(tc-getPKG_CONFIG) --cflags-only-I superlu | awk '{print $1}' | sed 's/-I//')"
- )
- else
- mycmakeargs+=(
- -DSuperLU_FOUND=OFF
- )
- fi
-
- cmake-utils_src_configure
-}
-
-src_test() {
- pushd examples > /dev/null
- emake \
- CXX="$(tc-getCXX)" \
- CXXFLAGS="-I../include ${CXXFLAGS} -DARMA_USE_BLAS -DARMA_USE_LAPACK" \
- LIB_FLAGS="-L.. -larmadillo $($(tc-getPKG_CONFIG) --libs blas lapack)"
- LD_LIBRARY_PATH="..:${LD_LIBRARY_PATH}" ./example1 || die
- emake clean
- popd > /dev/null
-}
-
-src_install() {
- cmake-utils_src_install
- dodoc README.txt
- use doc && dodoc *pdf *html
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/*
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
diff --git a/sci-libs/armadillo/armadillo-9.850.1.ebuild b/sci-libs/armadillo/armadillo-9.850.1.ebuild
deleted file mode 100644
index 1450070b53ca..000000000000
--- a/sci-libs/armadillo/armadillo-9.850.1.ebuild
+++ /dev/null
@@ -1,148 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-CMAKE_IN_SOURCE_BUILD=1
-
-inherit cmake-utils toolchain-funcs multilib eutils
-
-DESCRIPTION="Streamlined C++ linear algebra library"
-HOMEPAGE="http://arma.sourceforge.net/"
-SRC_URI="mirror://sourceforge/arma/${P}.tar.xz"
-
-LICENSE="Apache-2.0"
-SLOT="0/9"
-KEYWORDS="~amd64 ~arm ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="arpack blas doc examples hdf5 lapack mkl superlu test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="test? ( lapack )"
-
-# atlas? ( sci-libs/atlas[lapack] )
-
-RDEPEND="
- dev-libs/boost
- arpack? ( sci-libs/arpack )
- blas? ( virtual/blas )
- lapack? ( virtual/lapack )
- superlu? ( >=sci-libs/superlu-5.2 )
-"
-
-DEPEND="${RDEPEND}
- arpack? ( virtual/pkgconfig )
- blas? ( virtual/pkgconfig )
- hdf5? ( sci-libs/hdf5 )
- lapack? ( virtual/pkgconfig )
- mkl? ( sci-libs/mkl )
-"
-PDEPEND="${RDEPEND}
- hdf5? ( sci-libs/hdf5 )
- mkl? ( sci-libs/mkl )
-"
-
-src_prepare() {
- # avoid the automagic cmake macros...
- sed -i -e 's/^ *include(ARMA_Find/# No automagic include(ARMA_Find/g' CMakeLists.txt || die
-
- # ... except for mkl, since without a license it's hard to figure out what to do there
- if use mkl; then
- sed -i -e 's/^# No automagic include(ARMA_FindMKL)/include(ARMA_FindMKL)/g' CMakeLists.txt || die
- fi
-
- cmake-utils_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DINSTALL_LIB_DIR="${EPREFIX}/usr/$(get_libdir)"
- )
- if use arpack; then
- mycmakeargs+=(
- -DARPACK_FOUND=ON
- -DARPACK_LIBRARY="$($(tc-getPKG_CONFIG) --libs arpack)"
- )
- else
- mycmakeargs+=(
- -DARPACK_FOUND=OFF
- )
- fi
-# if use atlas; then
-# local c=atlas-cblas l=atlas-clapack
-# $(tc-getPKG_CONFIG) --exists ${c}-threads && c+=-threads
-# $(tc-getPKG_CONFIG) --exists ${l}-threads && l+=-threads
-# mycmakeargs+=(
-# -DCBLAS_FOUND=ON
-# -DCBLAS_INCLUDE_DIR="$($(tc-getPKG_CONFIG) --cflags-only-I ${c} | sed 's/-I//')"
-# -DCBLAS_LIBRARIES="$($(tc-getPKG_CONFIG) --libs ${c})"
-# -DCLAPACK_FOUND=ON
-# -DCLAPACK_INCLUDE_DIR="$($(tc-getPKG_CONFIG) --cflags-only-I ${l} | sed 's/-I//')"
-# -DCLAPACK_LIBRARIES="$($(tc-getPKG_CONFIG) --libs ${l})"
-# )
-# fi
- if use blas; then
- mycmakeargs+=(
- -DBLAS_FOUND=ON
- -DBLAS_LIBRARIES="$($(tc-getPKG_CONFIG) --libs blas)"
- )
- else
- mycmakeargs+=(
- -DBLAS_FOUND=OFF
- )
- fi
- if use hdf5; then
- mycmakeargs+=(
- -DDETECT_HDF5=ON
- -DHDF5_LIBRARIES="-lhdf5"
- -DHDF5_INCLUDE_DIRS=/usr/include
- )
- else
- mycmakeargs+=(
- -DDETECT_HDF5=OFF
- )
- fi
- if use lapack; then
- mycmakeargs+=(
- -DLAPACK_FOUND=ON
- -DLAPACK_LIBRARIES="$($(tc-getPKG_CONFIG) --libs lapack)"
- )
- else
- mycmakeargs+=(
- -DLAPACK_FOUND=OFF
- )
- fi
- if use superlu; then
- mycmakeargs+=(
- -DSuperLU_FOUND=ON
- -DSuperLU_LIBRARY="$($(tc-getPKG_CONFIG) --libs superlu)"
- -DSuperLU_INCLUDE_DIR="$($(tc-getPKG_CONFIG) --cflags-only-I superlu | awk '{print $1}' | sed 's/-I//')"
- )
- else
- mycmakeargs+=(
- -DSuperLU_FOUND=OFF
- )
- fi
-
- cmake-utils_src_configure
-}
-
-src_test() {
- pushd examples > /dev/null
- emake \
- CXX="$(tc-getCXX)" \
- CXXFLAGS="-I../include ${CXXFLAGS} -DARMA_USE_BLAS -DARMA_USE_LAPACK" \
- LIB_FLAGS="-L.. -larmadillo $($(tc-getPKG_CONFIG) --libs blas lapack)"
- LD_LIBRARY_PATH="..:${LD_LIBRARY_PATH}" ./example1 || die
- emake clean
- popd > /dev/null
-}
-
-src_install() {
- cmake-utils_src_install
- dodoc README.md
- use doc && dodoc *pdf *html
- if use examples; then
- docinto /usr/share/doc/${PF}/examples
- dodoc -r examples/*
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
diff --git a/sci-libs/armadillo/metadata.xml b/sci-libs/armadillo/metadata.xml
index b2dad09a9172..3daa0eb96588 100644
--- a/sci-libs/armadillo/metadata.xml
+++ b/sci-libs/armadillo/metadata.xml
@@ -9,32 +9,28 @@
<name>Gentoo Science Project</name>
</maintainer>
<longdescription lang="en">
- Armadillo is a C++ linear algebra library (matrix maths) aiming
- towards a good balance between speed and ease of use. Integer,
- floating point and complex numbers are supported, as well as a
- subset of trigonometric and statistics functions. Various matrix
- decompositions are provided through optional integration with LAPACK
- and ATLAS libraries.
- A delayed evaluation approach is employed (during compile time) to
- combine several operations into one and reduce (or eliminate) the
- need for temporaries. This is accomplished through recursive
- templates and template meta-programming.
-</longdescription>
+ Armadillo is a C++ linear algebra library (matrix maths) aiming
+ towards a good balance between speed and ease of use. Integer,
+ floating point and complex numbers are supported, as well as a
+ subset of trigonometric and statistics functions. Various matrix
+ decompositions are provided through optional integration with LAPACK
+ and ATLAS libraries.
+ A delayed evaluation approach is employed (during compile time) to
+ combine several operations into one and reduce (or eliminate) the
+ need for temporaries. This is accomplished through recursive
+ templates and template meta-programming.
+ </longdescription>
<use>
<flag name="arpack">
- Link with <pkg>sci-libs/arpack</pkg> libraries for eigen decomposition
- </flag>
+ Link with <pkg>sci-libs/arpack</pkg> libraries for eigen decomposition
+ </flag>
<flag name="mkl">
- Use matrix allocation from the Intel MKL <pkg>sci-libs/mkl</pkg>
- </flag>
- <flag name="tbb">
- Use matrix allocation from the Threads Building Blocks
- <pkg>dev-cpp/tbb</pkg>
- </flag>
+ Use matrix allocation from the Intel MKL <pkg>sci-libs/mkl</pkg>
+ </flag>
<flag name="superlu">
- Use SuperLU for sparse linear equation solving
- <pkg>sci-libs/superlu</pkg>
- </flag>
+ Use SuperLU for sparse linear equation solving
+ <pkg>sci-libs/superlu</pkg>
+ </flag>
</use>
<upstream>
<remote-id type="sourceforge">arma</remote-id>