summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:11:27 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:33 +0100
commite22301913ee45323f4c8385f180d9f58db8075ac (patch)
tree3352c575225f6e5f68adfbe039f28b111ddc71b8
parentdev-haskell/glib: new package, add 0.13.10.0 (diff)
downloadgentoo-e22301913ee45323f4c8385f180d9f58db8075ac.tar.gz
gentoo-e22301913ee45323f4c8385f180d9f58db8075ac.tar.bz2
gentoo-e22301913ee45323f4c8385f180d9f58db8075ac.zip
dev-haskell/pango: new package, add 0.13.10.0
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-haskell/pango/Manifest1
-rw-r--r--dev-haskell/pango/metadata.xml12
-rw-r--r--dev-haskell/pango/pango-0.13.10.0.ebuild32
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-haskell/pango/Manifest b/dev-haskell/pango/Manifest
new file mode 100644
index 000000000000..e7d95edab6a2
--- /dev/null
+++ b/dev-haskell/pango/Manifest
@@ -0,0 +1 @@
+DIST pango-0.13.10.0.tar.gz 52695 BLAKE2B 5551b0352b8c444de6ad6cfb216e571ef71b38e76d4d174ac9dd090bc3cec7c3c395065cf2a90e889ce945939ef5cd64715d443283cb350c78b99bc7ab02879b SHA512 050729ddf2a35bd21836a3a67eaa7218faf3534ff1affe74be840b6a7cfff256cc207b7805d5e3a48f6f6c365e3b0793818f98e94fc4a9dd03c31e1a60e7d078
diff --git a/dev-haskell/pango/metadata.xml b/dev-haskell/pango/metadata.xml
new file mode 100644
index 000000000000..584240bb2f12
--- /dev/null
+++ b/dev-haskell/pango/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="hackage">pango</remote-id>
+ <remote-id type="github">gtk2hs/gtk2hs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/pango/pango-0.13.10.0.ebuild b/dev-haskell/pango/pango-0.13.10.0.ebuild
new file mode 100644
index 000000000000..1beb5cff52e8
--- /dev/null
+++ b/dev-haskell/pango/pango-0.13.10.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Binding to the Pango text rendering engine"
+HOMEPAGE="https://projects.haskell.org/gtk2hs/"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-haskell/cairo-0.13.0.0:=[profile?] <dev-haskell/cairo-0.14:=[profile?]
+ >=dev-haskell/glib-0.13.0.0:=[profile?] <dev-haskell/glib-0.14:=[profile?]
+ >=dev-haskell/text-0.11.0.6:=[profile?] <dev-haskell/text-2.1:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+ x11-libs/cairo
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0 <dev-haskell/cabal-3.11
+"
+BDEPEND="virtual/pkgconfig
+ >=dev-haskell/gtk2hs-buildtools-0.13.2.0 <dev-haskell/gtk2hs-buildtools-0.14
+"
+
+GHC_BOOTSTRAP_PACKAGES=( gtk2hs-buildtools )