summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2020-06-24 14:21:26 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2020-06-24 14:22:00 -0700
commite2b549a82496d0f5c1daa29d9ea1b81ff0b68ec2 (patch)
treeaaf6ad5208fdfa767df71364a732c3f530ba578b
parentapp-emulation/virtualbox: [QA] Remove $Id$ line from header. (diff)
downloadgentoo-e2b549a82496d0f5c1daa29d9ea1b81ff0b68ec2.tar.gz
gentoo-e2b549a82496d0f5c1daa29d9ea1b81ff0b68ec2.tar.bz2
gentoo-e2b549a82496d0f5c1daa29d9ea1b81ff0b68ec2.zip
app-text/q-text-as-data: bump, now with py3 support
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
-rw-r--r--app-text/q-text-as-data/Manifest1
-rw-r--r--app-text/q-text-as-data/q-text-as-data-2.0.10.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-text/q-text-as-data/Manifest b/app-text/q-text-as-data/Manifest
index 081b6340c159..9078adf23ebc 100644
--- a/app-text/q-text-as-data/Manifest
+++ b/app-text/q-text-as-data/Manifest
@@ -1 +1,2 @@
DIST q-1.5.0.tar.gz 58746 BLAKE2B a35f7ea605a42e81be1ee4899ed9e8c2b4e81e896b6e4c1eb6045b64cc7fa3ffdf6f754be168b3ebe25faa4c8b80f63e2ffff3174231357260263acf335b8d5c SHA512 d21dd16a31629e36f0dee72ebc574283c7937821cb2da7ccaacb8484a35b53193dad05fe9857d1498434a0c1083514ea5b9e5d8a636bcd51d4c5924cb7bb1b55
+DIST q-2.0.10.tar.gz 218824 BLAKE2B 91f6485d94325768d7bfd32223d379cd90f3ade3760e44c859ec25aee6aeb73c943b3dedbf56b378222f6bc094faf160d86dcacab3dd0ce5ebf93230ca61696d SHA512 ab503a555380b6d17500972256db5e9eb19066d7a1f480091e777681d694746d6d7743254f3839bfd2f08697308aee8cea60e4583a0b1a4d93caf522342f25b2
diff --git a/app-text/q-text-as-data/q-text-as-data-2.0.10.ebuild b/app-text/q-text-as-data/q-text-as-data-2.0.10.ebuild
new file mode 100644
index 000000000000..f3c988259f1b
--- /dev/null
+++ b/app-text/q-text-as-data/q-text-as-data-2.0.10.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python2_7 python3_{6..9} )
+PYTHON_REQ_USE="sqlite"
+
+inherit python-r1
+
+DESCRIPTION="A CLI tool that allows direct execution of SQL-like queries on text"
+HOMEPAGE="http://harelba.github.io/q/"
+MY_P="q-${PV}"
+SRC_URI="https://github.com/harelba/q/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Upstream is wrong
+# http://harelba.github.io/q/#requirements
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_any_dep '
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/flake8[${PYTHON_USEDEP}]
+ ')"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ : # Do not use the Makefile
+}
+
+q_install() {
+ python_newexe bin/q.py q-text-as-data
+}
+
+src_install() {
+ python_foreach_impl q_install
+ newdoc bin/.qrc dot-qrc
+ dodoc doc/*
+}
+
+pkg_postinst() {
+ einfo "On Gentoo, the 'q' binary is most often provided by app-portage/portage-utils;"
+ einfo "Thus, this tool is install as 'q-text-as-data' rather than 'q'."
+}