summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-03-04 10:17:10 -0600
committerWilliam Hubbs <williamh@gentoo.org>2023-03-04 10:17:40 -0600
commite2d9f70d9cd6327c126582adff89862a2c99d724 (patch)
tree52ea69b9c91493c7ffe608fe804251bc2e8f85ad
parentsys-apps/ethtool: Stabilize 6.1 hppa, #899348 (diff)
downloadgentoo-e2d9f70d9cd6327c126582adff89862a2c99d724.tar.gz
gentoo-e2d9f70d9cd6327c126582adff89862a2c99d724.tar.bz2
gentoo-e2d9f70d9cd6327c126582adff89862a2c99d724.zip
dev-vcs/python-gitlab: add 3.13.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--dev-vcs/python-gitlab/Manifest1
-rw-r--r--dev-vcs/python-gitlab/python-gitlab-3.13.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-vcs/python-gitlab/Manifest b/dev-vcs/python-gitlab/Manifest
index 6acc87f4d9ae..74499464b158 100644
--- a/dev-vcs/python-gitlab/Manifest
+++ b/dev-vcs/python-gitlab/Manifest
@@ -1 +1,2 @@
DIST python-gitlab-3.12.0.tar.gz 264005 BLAKE2B 64215b0c2950b1d238ff0e69e88de463ce2645d7c3911963e516b50874b49c4e822f8e27625fa33e6d27a703cc3bb3377151a9bc9c49b0b49ee7bc57db5dfd65 SHA512 76f55945a821553b4b477629dea674956459836df227e70817480b031559317ec97fef6c332d0dc42c4dba0d556ed1118e1cded8f116f4813bebe411db9e7a47
+DIST python-gitlab-3.13.0.tar.gz 270646 BLAKE2B ff7e3c35525ac1bf1cb6dc6e668ca9c8aeefb12073636f115c8e078aa4b9f623f6d847d8487e85e9a325b6f0ad1ef93826631cb32fd86c0bd9023688aac5add9 SHA512 373347392d7030c817a8dcb4cceea71d0609f9e09dce348514c1ca024307094b1a72e287c871ce5fcba9b9d4cdfcc7dc6b4495e2b225b845a3dff2e2dfc4fe82
diff --git a/dev-vcs/python-gitlab/python-gitlab-3.13.0.ebuild b/dev-vcs/python-gitlab/python-gitlab-3.13.0.ebuild
new file mode 100644
index 000000000000..2fad79ea4fa9
--- /dev/null
+++ b/dev-vcs/python-gitlab/python-gitlab-3.13.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9,10,11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Python command line interface to gitlab API"
+HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/python-gitlab/python-gitlab"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-3"
+SLOT="0"
+
+BDEPEND="test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ >=dev-python/pytest-console-scripts-1.3.1[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.2[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )"
+
+RDEPEND=">=dev-python/requests-2.28.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.10.1[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc -r *.rst docs
+}