summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-04-28 10:35:02 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-28 10:35:58 +0300
commite37e23adc7675425c59b79c24c56634ba2793dc9 (patch)
tree884d453ef63ffccdf9c2a0ab33879695e4c45de7
parentapp-editors/emacs: drop 26.3-r17, 27.2-r15, 28.2-r11 (diff)
downloadgentoo-e37e23adc7675425c59b79c24c56634ba2793dc9.tar.gz
gentoo-e37e23adc7675425c59b79c24c56634ba2793dc9.tar.bz2
gentoo-e37e23adc7675425c59b79c24c56634ba2793dc9.zip
sci-physics/heppdt: EAPI 6 -> 8
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--sci-physics/heppdt/heppdt-3.04.01-r2.ebuild (renamed from sci-physics/heppdt/heppdt-3.04.01-r1.ebuild)25
1 files changed, 9 insertions, 16 deletions
diff --git a/sci-physics/heppdt/heppdt-3.04.01-r1.ebuild b/sci-physics/heppdt/heppdt-3.04.01-r2.ebuild
index 9f5e3c36d28e..8751a4c1512d 100644
--- a/sci-physics/heppdt/heppdt-3.04.01-r1.ebuild
+++ b/sci-physics/heppdt/heppdt-3.04.01-r2.ebuild
@@ -1,33 +1,26 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools
-MY_P=HepPDT-${PV}
-
DESCRIPTION="Data about each particle from the Review of Particle Properties"
HOMEPAGE="http://lcgapp.cern.ch/project/simu/HepPDT/"
-SRC_URI="http://lcgapp.cern.ch/project/simu/HepPDT/download/${MY_P}.tar.gz"
+SRC_URI="http://lcgapp.cern.ch/project/simu/HepPDT/download/HepPDT-${PV}.tar.gz"
+S=${WORKDIR}/HepPDT-${PV}
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc examples static-libs"
-S="${WORKDIR}/${MY_P}"
-
src_prepare() {
default
# respect user flags
- sed -i \
- -e '/AC_SUBST(AM_CXXFLAGS)/d' \
- configure.ac || die
+ sed -i configure.ac -e '/AC_SUBST(AM_CXXFLAGS)/d' || die
# directories
- sed -i \
- -e 's:$(prefix)/data:$(datadir)/${PN}:g' \
- data/Makefile.am || die
+ sed -i data/Makefile.am -e 's:$(prefix)/data:$(datadir)/${PN}:g' || die
eautoreconf
}
@@ -44,11 +37,11 @@ src_install() {
default
if use doc; then
- mv "${ED%/}"/usr/doc/* "${ED%/}"/usr/share/doc/${PF}/ || die
+ mv "${ED}"/usr/doc/* "${ED}"/usr/share/doc/${PF}/ || die
fi
if use examples; then
- mv "${ED%/}"/usr/examples "${ED%/}"/usr/share/doc/${PF}/ || die
+ mv "${ED}"/usr/examples "${ED}"/usr/share/doc/${PF}/ || die
docompress -x /usr/share/doc/${PF}/examples
fi
- rm -rf "${ED%/}"/usr/{doc,examples} || die
+ rm -rf "${ED}"/usr/{doc,examples} || die
}