summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-03-03 14:05:49 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-03-03 14:05:49 +0100
commite4b19e023c5dedf5f79af3fa856ef576ef0ce5e5 (patch)
treef6b8265c9a89bb67db74cbf2eaaf864e92dabb9f
parentsys-kernel/vanilla-sources: add 6.2.2, drop 6.2.1 (diff)
downloadgentoo-e4b19e023c5dedf5f79af3fa856ef576ef0ce5e5.tar.gz
gentoo-e4b19e023c5dedf5f79af3fa856ef576ef0ce5e5.tar.bz2
gentoo-e4b19e023c5dedf5f79af3fa856ef576ef0ce5e5.zip
dev-python/python-mpv: add 1.0.3
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/python-mpv/Manifest1
-rw-r--r--dev-python/python-mpv/python-mpv-1.0.3.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/python-mpv/Manifest b/dev-python/python-mpv/Manifest
index 014a0708ee5c..45388a8324b8 100644
--- a/dev-python/python-mpv/Manifest
+++ b/dev-python/python-mpv/Manifest
@@ -1,2 +1,3 @@
DIST python-mpv-1.0.1.tar.gz 210008 BLAKE2B 3ba95ac4d3219615c80ea475c1f6dc3acd608a8ded919eea55efac8bb44a8946c959a2b39473e6c9e80fa1a4e52f525d6ef9871e3eb4b2664aeb1460208bc677 SHA512 16a6e93b63f30e535c1e3bd77702d7c703dd9c0a6a689f09e689663cac04e587bdc2135612062d791ffb38c709bc289d0297ebf9f1ddaf9b1771f25eae225f1b
DIST python-mpv-1.0.2.gh.tar.gz 210975 BLAKE2B 1a364761405e430ed91f597e15aae7f6c221980c2ed9ce0152109486d1fb79ebb7b6257c79bfef34d72468bcf335e8e514324bdd10982096a64f8949b4bca261 SHA512 62a1c682de8d0308a80b66d6f435fba8563abc84b16670c3ef55cc3d9295fd3ead7c68d99e64c06734c5be9017549a53bd760ca201146427abcfbf7aca610b7a
+DIST python-mpv-1.0.3.gh.tar.gz 211529 BLAKE2B 0701147415c920be4ec65151ed7844bb36c275bcc64ae07d4ece9a515a96ba09097a8f2282eb7bbb74e8dc143d14f9a0aebdfadad53e0e9e4d62fcde734c7d17 SHA512 30ed5751c5732eeda9150a1e0dc425d2846c1a5dcfd53b9568bca169e570401fc8b3d224c59a1a1f54c574a056ccb0f540a0dc389e47e0811b0a9a3de4fb7092
diff --git a/dev-python/python-mpv/python-mpv-1.0.3.ebuild b/dev-python/python-mpv/python-mpv-1.0.3.ebuild
new file mode 100644
index 000000000000..194d0f3edd53
--- /dev/null
+++ b/dev-python/python-mpv/python-mpv-1.0.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Python interface to the mpv media player"
+HOMEPAGE="https://github.com/jaseg/python-mpv"
+SRC_URI="https://github.com/jaseg/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ media-video/mpv[libmpv]
+ dev-python/pillow[${PYTHON_USEDEP}]
+"
+
+BDEPEND="test? ( dev-python/xvfbwrapper[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # https://github.com/jaseg/python-mpv/issues/209
+ EPYTEST_DESELECT=(
+ tests/test_mpv.py::TestLifecycle::test_wait_for_property_negative
+ tests/test_mpv.py::TestLifecycle::test_wait_for_property_positive
+ tests/test_mpv.py::TestLifecycle::test_wait_for_property_shutdown
+ tests/test_mpv.py::TestLifecycle::test_wait_for_prooperty_event_overflow
+ tests/test_mpv.py::TestLifecycle::test_event_callback
+ )
+ virtx epytest
+}