summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-13 18:19:04 -0400
committerSam James <sam@gentoo.org>2024-03-14 00:10:43 +0000
commite4e89132cedbe27e467ae19876c820976266e841 (patch)
tree8ea741ca220553b9f0faed1858b4827bc2a33240
parentsci-calculators/wcalc: mark as LTO-unsafe (diff)
downloadgentoo-e4e89132cedbe27e467ae19876c820976266e841.tar.gz
gentoo-e4e89132cedbe27e467ae19876c820976266e841.tar.bz2
gentoo-e4e89132cedbe27e467ae19876c820976266e841.zip
sci-calculators/wcalc: add patch to fix bashism
The software is dead upstream for several years, and it is sourceforge, so I haven't forwarded it. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-calculators/wcalc/files/0001-fix-bashism-in-configure-script.patch28
-rw-r--r--sci-calculators/wcalc/wcalc-2.5.ebuild5
2 files changed, 32 insertions, 1 deletions
diff --git a/sci-calculators/wcalc/files/0001-fix-bashism-in-configure-script.patch b/sci-calculators/wcalc/files/0001-fix-bashism-in-configure-script.patch
new file mode 100644
index 000000000000..97cd3772309b
--- /dev/null
+++ b/sci-calculators/wcalc/files/0001-fix-bashism-in-configure-script.patch
@@ -0,0 +1,28 @@
+From b533584038a4ab8709fb8c88d7c4441f22b5de78 Mon Sep 17 00:00:00 2001
+From: Eli Schwartz <eschwartz93@gmail.com>
+Date: Wed, 13 Mar 2024 18:15:00 -0400
+Subject: [PATCH] fix bashism in configure script
+
+double equals is horrid and banned. Do not ever use it, but definitely
+don't use it in POSIX sh, where it doesn't exist *even* as an alias for
+single equals.
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 1db142d..af541af 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -48,7 +48,7 @@ AC_PROG_RANLIB
+ AC_PROG_YACC
+ AM_PROG_AR
+ AM_PROG_LEX
+-AS_IF([test "x$LEX" == x],
++AS_IF([test "x$LEX" = x],
+ [AC_MSG_ERROR([A Lex/Flex program is required in order to compile wcalc.])],
+ [AS_IF([test "x$LEX" != xflex],
+ [LEX="$SHELL $missing_dir/missing flex"
+--
+2.43.2
+
diff --git a/sci-calculators/wcalc/wcalc-2.5.ebuild b/sci-calculators/wcalc/wcalc-2.5.ebuild
index edb093739358..6fd0f9e9cae0 100644
--- a/sci-calculators/wcalc/wcalc-2.5.ebuild
+++ b/sci-calculators/wcalc/wcalc-2.5.ebuild
@@ -20,7 +20,10 @@ RDEPEND="
readline? ( sys-libs/readline:0= )"
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}"/${P}-AR.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-AR.patch
+ "${FILESDIR}"/0001-fix-bashism-in-configure-script.patch
+)
src_prepare() {
default