summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2018-12-20 17:13:17 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-12-20 17:13:17 +0300
commite618763082b801b2f13e7210160f96ddf78e4804 (patch)
tree2f9a9687b7a8557670ed46cc9f6c64ab4d176993
parentkde-misc/basket: 2.49a_p20181205 snapshot bump (diff)
downloadgentoo-e618763082b801b2f13e7210160f96ddf78e4804.tar.gz
gentoo-e618763082b801b2f13e7210160f96ddf78e4804.tar.bz2
gentoo-e618763082b801b2f13e7210160f96ddf78e4804.zip
sys-apps/sed: Version bump (v4.6)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--sys-apps/sed/Manifest1
-rw-r--r--sys-apps/sed/sed-4.6.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/sys-apps/sed/Manifest b/sys-apps/sed/Manifest
index a93fc1f8ff9a..9b599ab7ec6f 100644
--- a/sys-apps/sed/Manifest
+++ b/sys-apps/sed/Manifest
@@ -1 +1,2 @@
DIST sed-4.5.tar.xz 1274252 BLAKE2B 08525659e0e01ec50e736c1665634f3816f57c48aeefa7f6bc7a152cd6c171bb4e96e5c215429fc5edbe6e1de6cc3efe4f2f3bf6865933a30dd1700e921d5b3f SHA512 f95fb27e03b2301dae63878413b4c48e40341cc676945a612e1d0bd911da3192858ae142791292a99fbdaacbc7dab2d6fccb50787c06846f99b0b3740b40c196
+DIST sed-4.6.tar.xz 1297724 BLAKE2B 8563593c03953fe0ae6045af6c1d913d346ea69fe21559866e331a310b44eb17c96ca02137975350bcf3759e7a0406f40ffd1f88eaf61a740b595435a9789da8 SHA512 dba1d3a7867e4b20266fe4aae88fa779985b6554ef0eeedbf0d2124fa91745419ad843ed20f38ce734c778a2702d3530e92a0b12ce83e546cf093ad612c44e0b
diff --git a/sys-apps/sed/sed-4.6.ebuild b/sys-apps/sed/sed-4.6.ebuild
new file mode 100644
index 000000000000..d9ed95034e28
--- /dev/null
+++ b/sys-apps/sed/sed-4.6.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Super-useful stream editor"
+HOMEPAGE="http://sed.sourceforge.net/"
+SRC_URI="mirror://gnu/sed/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="acl forced-sandbox nls selinux static"
+
+RDEPEND="acl? ( virtual/acl )
+ nls? ( virtual/libintl )
+ selinux? ( sys-libs/libselinux )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_bootstrap_sed() {
+ # make sure system-sed works #40786 #650052
+ if ! type -p sed > /dev/null || has_version 'sys-apps/sed[forced-sandbox]' ; then
+ mkdir -p "${T}/bootstrap"
+ printf '#!/bin/sh\nexec busybox sed "$@"\n' > "${T}/bootstrap/sed" || die
+ chmod a+rx "${T}/bootstrap/sed"
+ PATH="${T}/bootstrap:${PATH}"
+ fi
+}
+
+src_prepare() {
+ # Don't use sed before bootstrap if we have to recover a broken host sed.
+ src_bootstrap_sed
+
+ default
+
+ if use forced-sandbox ; then
+ # Upstream doesn't want to add a configure flag for this.
+ # https://lists.gnu.org/archive/html/bug-sed/2018-03/msg00001.html
+ sed -i \
+ -e '/^bool sandbox = false;/s:false:true:' \
+ sed/sed.c || die
+ # Make sure the sed took.
+ grep -q '^bool sandbox = true;' sed/sed.c || die "forcing sandbox failed"
+ fi
+}
+
+src_configure() {
+ local myconf=()
+ if use userland_GNU; then
+ myconf+=( --exec-prefix="${EPREFIX}" )
+ else
+ myconf+=( --program-prefix=g )
+ fi
+
+ export ac_cv_search_setfilecon=$(usex selinux -lselinux)
+ export ac_cv_header_selinux_{context,selinux}_h=$(usex selinux)
+ use static && append-ldflags -static
+ myconf+=(
+ $(use_enable acl)
+ $(use_enable nls)
+ )
+ econf "${myconf[@]}"
+}