summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-11-24 20:48:04 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-11-24 20:50:34 +0100
commite659e8b5323476bf99ebd71b1f2588990cf4f7d6 (patch)
tree0fc8f5ccb2227cdc78cecd4eafbc75131e133436
parentRevert "dev-python/snakeoil: Remove old" (needed for releng testing, no keywo... (diff)
downloadgentoo-e659e8b5323476bf99ebd71b1f2588990cf4f7d6.tar.gz
gentoo-e659e8b5323476bf99ebd71b1f2588990cf4f7d6.tar.bz2
gentoo-e659e8b5323476bf99ebd71b1f2588990cf4f7d6.zip
Revert "dev-util/catalyst: Remove old" (needed for releng testing, no keywords)
This reverts commit bd31e00e0730294b759ff99d95241d6d7d44cd5b. Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
-rw-r--r--dev-util/catalyst/Manifest1
-rw-r--r--dev-util/catalyst/catalyst-3.0.18.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-util/catalyst/Manifest b/dev-util/catalyst/Manifest
index ed98acb9b3cf..7bf82317e463 100644
--- a/dev-util/catalyst/Manifest
+++ b/dev-util/catalyst/Manifest
@@ -1 +1,2 @@
+DIST catalyst-3.0.18.tar.bz2 621208 BLAKE2B 63f76634b96006ef4a751b0ce166ab36dcba3016234251b2e44e89b43b0c6909e57914007d6287e54584094ff7f064c0251a79f095c87e4c7957925e9d4605cd SHA512 94a30304b242b4e63cc14f34916acd68c03700876ba1cc2f516880f4e8365258de8b62db85cddc9492229414484ba6908edc91991b70b13da0578792b8b96aa3
DIST catalyst-3.0.20.tar.bz2 620395 BLAKE2B 24e1e1def627bccebea4da7b4c0f787d1b7e06cc3a830847896d71e997d859ecc2131a85d328f2d58226bbf2d459ca349d50b1af68b95bb06bfe8e1843f4c4aa SHA512 f2f2b0003a70b7843006155edca0971508d19199dfe803b85477d2f2fd0365304b9e65531cc19bfb06b83fa98dac11960b72001e899bed0f9b55c0f6881a853e
diff --git a/dev-util/catalyst/catalyst-3.0.18.ebuild b/dev-util/catalyst/catalyst-3.0.18.ebuild
new file mode 100644
index 000000000000..e66f66b6de2d
--- /dev/null
+++ b/dev-util/catalyst/catalyst-3.0.18.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == *9999* ]]; then
+ SRC_ECLASS="git-r3"
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/catalyst.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/catalyst.git/snapshot/${P}.tar.bz2"
+ # KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86"
+fi
+
+PYTHON_COMPAT=( python3_{8,9} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1 ${SRC_ECLASS}
+
+DESCRIPTION="Release metatool used for creating releases based on Gentoo Linux"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Catalyst"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="ccache doc +iso kernel_linux system-bootloader"
+
+DEPEND="
+ app-text/asciidoc
+ >=dev-python/snakeoil-0.6.5[${PYTHON_USEDEP}]
+ <dev-python/snakeoil-0.9.6[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/snakeoil-0.6.5[${PYTHON_USEDEP}]
+ <dev-python/snakeoil-0.9.6[${PYTHON_USEDEP}]
+ >=dev-python/pydecomp-0.3[${PYTHON_USEDEP}]
+ app-arch/lbzip2
+ app-crypt/shash
+ sys-fs/dosfstools
+ !kernel_FreeBSD? ( || ( app-arch/tar[xattr] app-arch/libarchive[xattr] ) )
+ kernel_FreeBSD? ( app-arch/libarchive[xattr] )
+ amd64? ( >=sys-boot/syslinux-3.72 )
+ x86? ( >=sys-boot/syslinux-3.72 )
+ ccache? ( dev-util/ccache )
+ iso? ( app-cdr/cdrtools )
+ kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )
+"
+PDEPEND="system-bootloader? ( >=sys-apps/memtest86+-5.01-r4
+ sys-boot/grub:2
+ amd64? ( sys-boot/grub[grub_platforms_efi-32,grub_platforms_efi-64] )
+ x86? ( sys-boot/grub[grub_platforms_efi-32] )
+ sys-boot/syslinux
+ sys-boot/shim )"
+
+python_prepare_all() {
+ python_setup
+ echo VERSION="${PV}" "${PYTHON}" setup.py set_version
+ VERSION="${PV}" "${PYTHON}" setup.py set_version || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # build the man pages and docs
+ emake
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use doc; then
+ dodoc files/HOWTO.html files/docbook-xsl.css
+ fi
+}