summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-30 11:48:57 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:02:50 +0100
commite7f687262f23f6aedddb20eb0deee99b9c8d4867 (patch)
treea7a949f7ee5d6fa06c54b0e73bee836afe1b8856
parentdev-haskell/rsa: add package (diff)
downloadgentoo-e7f687262f23f6aedddb20eb0deee99b9c8d4867.tar.gz
gentoo-e7f687262f23f6aedddb20eb0deee99b9c8d4867.tar.bz2
gentoo-e7f687262f23f6aedddb20eb0deee99b9c8d4867.zip
dev-haskell/wreq: add package
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--dev-haskell/wreq/Manifest1
-rw-r--r--dev-haskell/wreq/metadata.xml39
-rw-r--r--dev-haskell/wreq/wreq-0.5.3.2.ebuild74
3 files changed, 114 insertions, 0 deletions
diff --git a/dev-haskell/wreq/Manifest b/dev-haskell/wreq/Manifest
new file mode 100644
index 000000000000..8a75bfc17d78
--- /dev/null
+++ b/dev-haskell/wreq/Manifest
@@ -0,0 +1 @@
+DIST wreq-0.5.3.2.tar.gz 57521 BLAKE2B 2265e7f8abe371371d079f735d61917c0efa5b78e2d3e8965e3b720a94e89b3a7ae05824f54d6fe765c643ed81f506b12694355b0bf1d7b4c2e9198d08c2317c SHA512 5a2c62b973758cb8ce2bf20504e328090896fa25e7ee1f77b472d7cf5156e08b6d85bf4341ff45e44db1724070fcf3c0f21037fa0a79211a1767024328f7c779
diff --git a/dev-haskell/wreq/metadata.xml b/dev-haskell/wreq/metadata.xml
new file mode 100644
index 000000000000..887b9ecf25d1
--- /dev/null
+++ b/dev-haskell/wreq/metadata.xml
@@ -0,0 +1,39 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+
+ A web client library that is designed for ease of use.
+
+ Tutorial: &lt;http://www.serpentine.com/wreq/tutorial.html&gt;
+
+ Features include:
+
+ * Simple but powerful `lens`-based API
+
+ * A solid test suite, and built on reliable libraries like
+ http-client and lens
+
+ * Session handling includes connection keep-alive and pooling, and
+ cookie persistence
+
+ * Automatic response body decompression
+
+ * Powerful multipart form and file upload handling
+
+ * Support for JSON requests and responses, including navigation of
+ schema-less responses
+
+ * Basic and OAuth2 bearer authentication
+
+ * Early TLS support via the tls package
+ </longdescription>
+ <use>
+ <flag name="aws">Enable AWS tests</flag>
+ <flag name="httpbin">Install client</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-haskell/wreq/wreq-0.5.3.2.ebuild b/dev-haskell/wreq/wreq-0.5.3.2.ebuild
new file mode 100644
index 000000000000..1c01466b1a0e
--- /dev/null
+++ b/dev-haskell/wreq/wreq-0.5.3.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.2
+#hackport: flags: -developer,+doctest
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="An easy-to-use HTTP client library"
+HOMEPAGE="http://www.serpentine.com/wreq"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="aws httpbin"
+
+RDEPEND=">=dev-haskell/aeson-1.0.0.0:=[profile?]
+ >=dev-haskell/attoparsec-0.11.1.0:=[profile?]
+ >=dev-haskell/authenticate-oauth-1.5:=[profile?]
+ dev-haskell/base16-bytestring:=[profile?]
+ dev-haskell/case-insensitive:=[profile?]
+ dev-haskell/cryptonite:=[profile?]
+ >=dev-haskell/exceptions-0.5:=[profile?]
+ dev-haskell/hashable:=[profile?]
+ >=dev-haskell/http-client-0.6:=[profile?]
+ >=dev-haskell/http-client-tls-0.3.3:=[profile?]
+ >=dev-haskell/http-types-0.8:=[profile?]
+ >=dev-haskell/lens-4.5:=[profile?]
+ dev-haskell/lens-aeson:=[profile?]
+ dev-haskell/memory:=[profile?]
+ dev-haskell/mime-types:=[profile?]
+ >=dev-haskell/psqueues-0.2:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/time-locale-compat:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ >=dev-lang/ghc-7.10.1:=
+ httpbin? ( >=dev-haskell/aeson-pretty-0.8.0:=[profile?]
+ dev-haskell/base64-bytestring:=[profile?]
+ >=dev-haskell/snap-core-1.0.0.0:=[profile?]
+ >=dev-haskell/snap-server-0.9.4.4:=[profile?]
+ dev-haskell/unix-compat:=[profile?]
+ dev-haskell/uuid:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.22.2.0
+ >=dev-haskell/cabal-doctest-1.0.2 <dev-haskell/cabal-doctest-1.1
+ test? ( dev-haskell/doctest
+ dev-haskell/hunit
+ dev-haskell/network-info
+ >=dev-haskell/quickcheck-2.7
+ dev-haskell/temporary
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ dev-haskell/test-framework-quickcheck2
+ dev-haskell/vector
+ !httpbin? ( >=dev-haskell/aeson-pretty-0.8.0
+ dev-haskell/base64-bytestring
+ >=dev-haskell/snap-core-1.0.0.0
+ >=dev-haskell/snap-server-0.9.4.4
+ dev-haskell/unix-compat
+ dev-haskell/uuid ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag aws aws) \
+ --flag=-developer \
+ --flag=doctest \
+ $(cabal_flag httpbin httpbin)
+}