summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-10-24 22:11:46 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-10-24 22:51:33 +0000
commite98d7df4068a1a7a04b1109b7a938315bfccf102 (patch)
treed95b8e36b52294388e2721148aeebb77a0a1d273
parentx11-base/xorg-drivers: Import 9999 ebuild. (diff)
downloadgentoo-e98d7df4068a1a7a04b1109b7a938315bfccf102.tar.gz
gentoo-e98d7df4068a1a7a04b1109b7a938315bfccf102.tar.bz2
gentoo-e98d7df4068a1a7a04b1109b7a938315bfccf102.zip
dev-python/pytest-mpl: initial import
Package-Manager: portage-2.3.2
-rw-r--r--dev-python/pytest-mpl/Manifest1
-rw-r--r--dev-python/pytest-mpl/metadata.xml15
-rw-r--r--dev-python/pytest-mpl/pytest-mpl-0.5.ebuild32
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pytest-mpl/Manifest b/dev-python/pytest-mpl/Manifest
new file mode 100644
index 000000000000..d34fbe1e582e
--- /dev/null
+++ b/dev-python/pytest-mpl/Manifest
@@ -0,0 +1 @@
+DIST pytest-mpl-0.5.tar.gz 112523 SHA256 fee0da4a81e2a3e966cf6488a6bcc81a144688e145048ad1f66799a25135dad3 SHA512 9056982403994572a33c861ebe0d7bbcb48579ef95f7cf93f716f06510fa09c187a8daad0ed4a55667444b74461a5a02d7f9217d89de57f3cc10116c88aaa662 WHIRLPOOL 4416015f78113bcfc74119a8a04fa55385e496395be9af2e7bcda317ac846744e0bf1221e18eac28efdc5a2b5a5305b2eaa25eef4c8c1051e1949702e92768d6
diff --git a/dev-python/pytest-mpl/metadata.xml b/dev-python/pytest-mpl/metadata.xml
new file mode 100644
index 000000000000..53dc3963e0d4
--- /dev/null
+++ b/dev-python/pytest-mpl/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="pypi">pytest-mpl</remote-id>
+ <remote-id type="github">astrofrog/pytest-mpl</remote-id>
+ </upstream>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ This is a plugin to faciliate image comparison for Matplotlib figures in pytest.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/pytest-mpl/pytest-mpl-0.5.ebuild b/dev-python/pytest-mpl/pytest-mpl-0.5.ebuild
new file mode 100644
index 000000000000..b383a41f544a
--- /dev/null
+++ b/dev-python/pytest-mpl/pytest-mpl-0.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit distutils-r1 virtualx
+
+DOCS=( README.md CHANGES.md )
+
+DESCRIPTION="pytest plugin to faciliate image comparison for matplotlib figures"
+HOMEPAGE="https://github.com/astrofrog/pytest-mpl/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ echo "backend : Agg" > matplotlibrc || die
+ MPLCONFIGDIR=. virtx py.test -v || die
+}