summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2023-09-10 12:39:21 +0200
committerFabian Groffen <grobian@gentoo.org>2023-09-10 12:40:57 +0200
commite9e471bcd35a1f9db45800dfd72fb7bae20c2caf (patch)
tree19787e125d140c5bba0ccfcd6bd649669ebe71c1
parentdev-libs/openssl-3.1.2: added Prefix keywords (diff)
downloadgentoo-e9e471bcd35a1f9db45800dfd72fb7bae20c2caf.tar.gz
gentoo-e9e471bcd35a1f9db45800dfd72fb7bae20c2caf.tar.bz2
gentoo-e9e471bcd35a1f9db45800dfd72fb7bae20c2caf.zip
dev-vcs/hg-git-1.0.2-r1: revbump for mercurial-6.5 compatibility
Signed-off-by: Fabian Groffen <grobian@gentoo.org>
-rw-r--r--dev-vcs/hg-git/Manifest1
-rw-r--r--dev-vcs/hg-git/hg-git-1.0.2-r1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-vcs/hg-git/Manifest b/dev-vcs/hg-git/Manifest
index 0dc6721abb12..881a484d9500 100644
--- a/dev-vcs/hg-git/Manifest
+++ b/dev-vcs/hg-git/Manifest
@@ -1,2 +1,3 @@
+DIST 1.0.2-hg65.patch 1697 BLAKE2B a620b6624eaad4ff233e9cda97d160acc11402e668a7837385bbf3d6384b19106084054e45d0f63dbe686267e636c3bd862a45b09f52ff93bb588ed3439dc69a SHA512 3ac84637f89b97347cd01c243df9af8b37a8c694fab3e560c8e5fd8baed6e0d695c1cd2cb22580378c57afa01aeee25915ac033444e833d0719bc1defdebc305
DIST hg-git-0.10.3.tar.bz2 146867 BLAKE2B cad4103cbb517c7126787fcfd5c6a9d20b814048e8277eddd1f398bb4e040cdf61d1a83ffb1a121ca62c9f038124049864c9d792ec500fd15614e7a1e2c70084 SHA512 61122084d89b62faaabfc93a8b3ef346c1c34ac3a4eea927f3f32a50490ce537333fb9e19452c2a02e172c216095d6a9db83f79d1f3ecb8afc7ae4cd554e0abc
DIST hg-git-1.0.2.tar.bz2 171241 BLAKE2B fd953178daff4e283cdacfacafd64c40efff73d0e4a175faa4e032bf38ccc1ef04bd715c4f38dd5d83ab1b0f52a1f329d2a1fb95c13ea83311c47786c3738600 SHA512 8df398c059131b4a8f4ab68fde743cfd82b19b3a184ea92f53ac69ba74e0b9cb94366d4a22d595ea44667493f050bd31ee3e9d7632cdb16507c57e156cd611e9
diff --git a/dev-vcs/hg-git/hg-git-1.0.2-r1.ebuild b/dev-vcs/hg-git/hg-git-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..6cff7305c62b
--- /dev/null
+++ b/dev-vcs/hg-git/hg-git-1.0.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+MY_PV=${PV/_rc/a}
+DESCRIPTION="push to and pull from a Git repository using Mercurial"
+HOMEPAGE="https://hg-git.github.io https://pypi.org/project/hg-git/"
+SRC_URI="https://foss.heptapod.net/mercurial/hg-git/-/archive/${MY_PV}/${PN}-${MY_PV}.tar.bz2 https://foss.heptapod.net/mercurial/hg-git/-/commit/9a52223a95e9821b2f2b544ab5a35e06963da3f1.patch -> ${MY_PV}-hg65.patch"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE=""
+
+RDEPEND="
+ >=dev-vcs/mercurial-5.2[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.19.3[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ default
+
+ eapply "${DISTDIR}"/${MY_PV}-hg65.patch
+}