summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2023-02-08 11:47:45 +0100
committerGuilherme Amadio <amadio@gentoo.org>2023-02-08 11:57:19 +0100
commitea3674f6953e77301ca2d99be970b17c94dada66 (patch)
tree27965233550b736a663e11b15f84c914c1c8aabf
parentnet-libs/davix: stabilize 0.8.3 for x86 (diff)
downloadgentoo-ea3674f6953e77301ca2d99be970b17c94dada66.tar.gz
gentoo-ea3674f6953e77301ca2d99be970b17c94dada66.tar.bz2
gentoo-ea3674f6953e77301ca2d99be970b17c94dada66.zip
net-libs/davix: drop 0.7.6
Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
-rw-r--r--net-libs/davix/Manifest1
-rw-r--r--net-libs/davix/davix-0.7.6.ebuild82
2 files changed, 0 insertions, 83 deletions
diff --git a/net-libs/davix/Manifest b/net-libs/davix/Manifest
index 7e03c70554eb..1311cb200d7d 100644
--- a/net-libs/davix/Manifest
+++ b/net-libs/davix/Manifest
@@ -1,2 +1 @@
-DIST davix-0.7.6.tar 4338692 BLAKE2B 72a918f52993ea358f243df671823a4624ac5650753e06c8f70f75a800f10adfe7f6c63d9c8fdcefb94874e3c60c3909e7aa96969af1210347ea941a42f4b9df SHA512 3e379acc763e72e2e1684121e2688da6c617b2c1f52ffd7a2a2559998a64aba957f09f7b138c57f8f4d7a26caff4fef09952cca48585bb4f6aea1f071aa9a7b7
DIST davix-0.8.3.tar.gz 7615016 BLAKE2B 7bb9ba6e267439db0f8b42d2a2b48ded801e3a10d6443101918514f999922e9cabce485b7a666ee0c1fb60d18cd537aa76b93096eeb0445b5ce4b25e214496d4 SHA512 ce5c66e8d59710e5658a6bb9bebdce3749843ab672274171f936cc533ce42689e1f75454de2a71529df97eb182d996c4ade00f30e1b21891fbfe4a40b1dd2dc5
diff --git a/net-libs/davix/davix-0.7.6.ebuild b/net-libs/davix/davix-0.7.6.ebuild
deleted file mode 100644
index 015f1c2d8452..000000000000
--- a/net-libs/davix/davix-0.7.6.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="High-performance file management over WebDAV/HTTP"
-HOMEPAGE="https://dmc.web.cern.ch/projects/davix"
-SRC_URI="http://grid-deployment.web.cern.ch/grid-deployment/dms/lcgutil/tar/${PN}/${PV}/${P}.tar.gz -> ${P}.tar"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc ipv6 test tools"
-RESTRICT="!test? ( test )"
-
-CDEPEND="
- dev-libs/libxml2:2=
- dev-libs/openssl:0=
- net-libs/gsoap[ssl,-gnutls]
- kernel_linux? ( sys-apps/util-linux )
-"
-
-DEPEND="${CDEPEND}"
-BDEPEND="
- doc? (
- app-doc/doxygen[dot]
- dev-python/sphinx
- )
- virtual/pkgconfig
-"
-
-RDEPEND="${CDEPEND}"
-
-REQUIRED_USE="test? ( tools )"
-
-src_prepare() {
- cmake_src_prepare
-
- for x in doc test; do
- if ! use $x; then
- sed -i -e "/add_subdirectory ($x)/d" CMakeLists.txt
- fi
- done
-}
-
-src_configure() {
- local mycmakeargs=(
- -DDOC_INSTALL_DIR="${EPREFIX}/usr/share/doc/${P}"
- -DENABLE_HTML_DOCS=$(usex doc)
- -DENABLE_IPV6=$(usex ipv6)
- -DENABLE_TCP_NODELAY=TRUE
- -DENABLE_THIRD_PARTY_COPY=TRUE
- -DENABLE_TOOLS=$(usex tools)
- -DHTML_INSTALL_DIR="${EPREFIX}/usr/share/doc/${P}/html"
- -DSOUND_INSTALL_DIR="${EPREFIX}/usr/share/${PN}/sounds"
- -DSTATIC_LIBRARY=OFF
- -DSYSCONF_INSTALL_DIR="${EPREFIX}/etc"
- -DBUILD_TESTING=$(usex test)
- )
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- if use doc; then
- cmake_src_compile doc
- fi
-}
-
-src_install() {
- cmake_src_install
-
- if ! use tools; then
- rm -rf "${ED}/usr/share/man/man1"
- fi
-
- if use test; then
- rm -rf "${ED}/usr/bin/davix-unit-tests"
- fi
-}