summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-02 08:54:44 +0100
committerSam James <sam@gentoo.org>2021-04-03 16:54:40 +0100
commitea41bb7b4ab58746db86925a4933438bacd074e8 (patch)
tree90020e64dd6ccda8a6376d7d3e1c5bd7e439dea0
parentdev-libs/yaz: eutils-- (diff)
downloadgentoo-ea41bb7b4ab58746db86925a4933438bacd074e8.tar.gz
gentoo-ea41bb7b4ab58746db86925a4933438bacd074e8.tar.bz2
gentoo-ea41bb7b4ab58746db86925a4933438bacd074e8.zip
dev-libs/yaz: port to EAPI 7, fix (automagic) deps
* EAPI 7 * Fix Prefix installation (prefix docdir and mv) * Add missing deps ** net-libs/gnutls ** sys-devel/bison ** sys-libs/readline ** sys-libs/ncurses ** virtual/libintl Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-libs/yaz/files/yaz-3.0.47-icu-automagic.patch4
-rw-r--r--dev-libs/yaz/yaz-3.0.53.ebuild47
2 files changed, 30 insertions, 21 deletions
diff --git a/dev-libs/yaz/files/yaz-3.0.47-icu-automagic.patch b/dev-libs/yaz/files/yaz-3.0.47-icu-automagic.patch
index a0aedfe05105..dd78635e013e 100644
--- a/dev-libs/yaz/files/yaz-3.0.47-icu-automagic.patch
+++ b/dev-libs/yaz/files/yaz-3.0.47-icu-automagic.patch
@@ -1,5 +1,5 @@
---- yaz-3.0.47/configure.ac.orig 2009-07-08 04:58:43.000000000 -0700
-+++ yaz-3.0.47/configure.ac 2009-07-31 01:46:21.764545198 -0700
+--- a/configure.ac
++++ b/configure.ac
@@ -367,14 +367,14 @@
dnl
diff --git a/dev-libs/yaz/yaz-3.0.53.ebuild b/dev-libs/yaz/yaz-3.0.53.ebuild
index fe1a1b52b350..847579e85f6b 100644
--- a/dev-libs/yaz/yaz-3.0.53.ebuild
+++ b/dev-libs/yaz/yaz-3.0.53.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit autotools
@@ -12,22 +12,34 @@ SRC_URI="http://ftp.indexdata.dk/pub/${PN}/${P}.tar.gz"
LICENSE="BSD GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ~ppc ppc64 ~s390 ~sparc x86"
-IUSE="debug icu libressl tcpd ziffy"
+IUSE="debug icu gnutls tcpd ziffy"
-RDEPEND="dev-libs/libxml2
+RDEPEND="
+ dev-libs/libxml2
dev-libs/libxslt
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
+ sys-libs/readline:=
+ sys-libs/ncurses:=
+ virtual/libintl
+ !gnutls? ( dev-libs/openssl:0= )
+ gnutls? ( net-libs/gnutls:= )
icu? ( dev-libs/icu:= )
tcpd? ( sys-apps/tcp-wrappers )
- ziffy? ( net-libs/libpcap )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
+ ziffy? ( net-libs/libpcap )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
dev-lang/tcl:0
- >=sys-devel/libtool-2"
+ sys-devel/bison
+ >=sys-devel/libtool-2
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0.47-icu-automagic.patch
+)
src_prepare() {
- epatch "${FILESDIR}"/${PN}-3.0.47-icu-automagic.patch
+ default
AT_M4DIR="m4" eautoreconf
}
@@ -36,22 +48,19 @@ src_configure() {
--enable-static \
--enable-shared \
$(use_enable debug memdebug) \
+ $(use_with gnutls) \
$(use_enable icu) \
$(use_enable tcpd tcpd /usr)
}
-src_compile() {
- emake
-}
-
src_install() {
local docdir="/usr/share/doc/${PF}"
- emake DESTDIR="${D}" docdir="${docdir}" install
+ emake DESTDIR="${D}" docdir="${EPREFIX}/${docdir}" install
- dodir ${docdir}/html
- mv -f "${D}"/${docdir}/*.{html,png} "${D}"/${docdir}/html/ || die "Failed to move HTML docs"
- mv -f "${D}"/usr/share/doc/${PN}/common "${D}"/${docdir}/html/ || die "Failed to move HTML docs"
- rm -rf "${D}"/usr/share/doc/${PN}
+ dodir "${docdir}"/html
+ mv -f "${ED}"/${docdir}/*.{html,png} "${ED}"/${docdir}/html/ || die "Failed to move HTML docs"
+ mv -f "${ED}"/usr/share/doc/${PN}/common "${ED}"/${docdir}/html/ || die "Failed to move HTML docs"
+ rm -rf "${ED}"/usr/share/doc/${PN} || die
dodoc ChangeLog NEWS README
}