summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-11-23 23:04:49 -0500
committerMike Gilbert <floppym@gentoo.org>2016-11-23 23:04:49 -0500
commitea604c2871dd4b3e6f902f6fa27ffe534e01236d (patch)
treef67a6858e9df4dc4c64e0cb797f0370294c0c56b
parentdev-python/progressbar: drop googlecode upstream element (diff)
downloadgentoo-ea604c2871dd4b3e6f902f6fa27ffe534e01236d.tar.gz
gentoo-ea604c2871dd4b3e6f902f6fa27ffe534e01236d.tar.bz2
gentoo-ea604c2871dd4b3e6f902f6fa27ffe534e01236d.zip
dev-python/pybluez: bump to 0.22
Package-Manager: portage-2.3.2_p8
-rw-r--r--dev-python/pybluez/Manifest1
-rw-r--r--dev-python/pybluez/metadata.xml1
-rw-r--r--dev-python/pybluez/pybluez-0.18-r1.ebuild4
-rw-r--r--dev-python/pybluez/pybluez-0.22.ebuild34
4 files changed, 37 insertions, 3 deletions
diff --git a/dev-python/pybluez/Manifest b/dev-python/pybluez/Manifest
index 2bd50d554f0f..a610aab50867 100644
--- a/dev-python/pybluez/Manifest
+++ b/dev-python/pybluez/Manifest
@@ -1 +1,2 @@
DIST PyBluez-0.18.tar.gz 74501 SHA256 66b2184e0eaad5e1ecc89eb4c81cba0696b3028b85d1301186b45b0bbd761065 SHA512 ddd185ad90f7c6235e25182afccfb586efa0d361f38140f33718dc2d29ca62f3aa68867d075820afffd5ee2fbd306b907b565fbdfdf32f906657f6a3a8c779da WHIRLPOOL 7cc0aaa8f5d33626689c10c4c171d0b5f115cbefda1c561b3146ae0f2b397739bf67a05f7f0ae330620194a54b595d408da81f11e07fcf51f4b176f60e11a7ba
+DIST PyBluez-0.22.zip 109060 SHA256 4ce006716a54d9d18e8186a3f1c8b12a8e6befecffe8fd5828a291fb694ce49d SHA512 c166a976d311eba73516aaf86ab42b100a39ebccd3d70f93ccb89f59c12127a857698dcfe4b25f8f689eee12187b5f35ccc8235e36cf012e73df155ba5adfae6 WHIRLPOOL 932fc01d1444b8f5ecb84ae27dc9f706591f18045129d7980ef9926fb5008ab5f19d879bbdd2c251402c9b41e474ac8284c5996dbe5cb3f81c6cc0a93f57f8f7
diff --git a/dev-python/pybluez/metadata.xml b/dev-python/pybluez/metadata.xml
index 041c2929aa4c..dc5ac4e13a1c 100644
--- a/dev-python/pybluez/metadata.xml
+++ b/dev-python/pybluez/metadata.xml
@@ -9,7 +9,6 @@
developers to use system bluetooth resources. It works on machines running the
GNU/Linux operating system and the bluez bluetooth stack.</longdescription>
<upstream>
- <remote-id type="google-code">pybluez</remote-id>
<remote-id type="github">karulis/pybluez</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/pybluez/pybluez-0.18-r1.ebuild b/dev-python/pybluez/pybluez-0.18-r1.ebuild
index 0fb4271d625e..d99bc6734cfa 100644
--- a/dev-python/pybluez/pybluez-0.18-r1.ebuild
+++ b/dev-python/pybluez/pybluez-0.18-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -12,7 +12,7 @@ MY_P="PyBluez-${PV}"
DESCRIPTION="Python bindings for Bluez Bluetooth Stack"
HOMEPAGE="https://github.com/karulis/pybluez"
-SRC_URI="https://pybluez.googlecode.com/files/${MY_P}.tar.gz"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
diff --git a/dev-python/pybluez/pybluez-0.22.ebuild b/dev-python/pybluez/pybluez-0.22.ebuild
new file mode 100644
index 000000000000..da677618289d
--- /dev/null
+++ b/dev-python/pybluez/pybluez-0.22.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+MY_P="PyBluez-${PV}"
+
+DESCRIPTION="Python bindings for Bluez Bluetooth Stack"
+HOMEPAGE="https://github.com/karulis/pybluez"
+SRC_URI="mirror://pypi/P/PyBluez/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples"
+
+RDEPEND="net-wireless/bluez"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x usr/share/doc/${PF}/examples
+ fi
+}