summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-07 17:17:44 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-07 17:17:44 +0100
commiteb73641f5a7ff69cb1329162ea2a9e59c861ad89 (patch)
tree8aea846b634fe780f00aad67eacc1d408e7ad3de
parentdev-python/pooch: Stabilize 1.8.1 ppc64, #926402 (diff)
downloadgentoo-eb73641f5a7ff69cb1329162ea2a9e59c861ad89.tar.gz
gentoo-eb73641f5a7ff69cb1329162ea2a9e59c861ad89.tar.bz2
gentoo-eb73641f5a7ff69cb1329162ea2a9e59c861ad89.zip
dev-python/anyio: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/anyio/Manifest1
-rw-r--r--dev-python/anyio/anyio-4.2.0.ebuild61
2 files changed, 0 insertions, 62 deletions
diff --git a/dev-python/anyio/Manifest b/dev-python/anyio/Manifest
index 966345215b8c..c0102b74ff06 100644
--- a/dev-python/anyio/Manifest
+++ b/dev-python/anyio/Manifest
@@ -1,2 +1 @@
-DIST anyio-4.2.0.tar.gz 158770 BLAKE2B 10ae621872edb27727c8931904c84f41dc18ef0cc4cce1ea18c957d479be24b1a4ffb15d8a9e2b4338663fdbc2a989e5772ba1bd2076f9f0b22f6f5c4feef4bc SHA512 a6f3cbedbfa063a5cf031cd833e6da7a23ee37dbdae8d47ccdfb09c61a73c186267f1a33ba6b4936cac7fb4c970f5488ff1464295e5ffa452952732ac0468d65
DIST anyio-4.3.0.tar.gz 159642 BLAKE2B 33b300d1da37137d45b311f8424c022d19518c207c39ec6f8bd3e42432cf1457f2d533eadeaa1e21853ed1b25a4f58818fc595e8588489722846f8a8d72262dc SHA512 26ff552a03b24b63c7c99cffcec61e97289eacba3ad2fc7a3c1dde8cfaffd9a8d621b867429901c12d7cef912d3807db134dbeb9c5ba619921160f6d5df4d02f
diff --git a/dev-python/anyio/anyio-4.2.0.ebuild b/dev-python/anyio/anyio-4.2.0.ebuild
deleted file mode 100644
index 4768f8c60a52..000000000000
--- a/dev-python/anyio/anyio-4.2.0.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Compatibility layer for multiple asynchronous event loop implementations"
-HOMEPAGE="
- https://github.com/agronholm/anyio/
- https://pypi.org/project/anyio/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/exceptiongroup-1.2.0[${PYTHON_USEDEP}]
- >=dev-python/idna-2.8[${PYTHON_USEDEP}]
- >=dev-python/sniffio-1.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/typing-extensions-4.1[${PYTHON_USEDEP}]
- ' 3.10)
-"
-# On amd64, let's get more test coverage by dragging in uvloop, but let's
-# not bother on other arches where uvloop may not be supported.
-BDEPEND="
- >=dev-python/setuptools-scm-6.4[${PYTHON_USEDEP}]
- test? (
- >=dev-python/hypothesis-4.0[${PYTHON_USEDEP}]
- >=dev-python/psutil-5.9[${PYTHON_USEDEP}]
- >=dev-python/pytest-mock-3.6.1[${PYTHON_USEDEP}]
- >=dev-python/trio-0.23[${PYTHON_USEDEP}]
- dev-python/trustme[${PYTHON_USEDEP}]
- amd64? (
- $(python_gen_cond_dep '
- >=dev-python/uvloop-0.17[${PYTHON_USEDEP}]
- ' python3_{10..12})
- )
- )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs \
- '>=dev-python/sphinx-rtd-theme-1.2.2' \
- dev-python/sphinxcontrib-jquery \
- dev-python/sphinx-autodoc-typehints
-
-python_test() {
- local EPYTEST_DESELECT=(
- # requires link-local IPv6 interface
- tests/test_sockets.py::TestTCPListener::test_bind_link_local
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -m 'not network'
-}