summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenri Gasc <gasc@eurecom.fr>2023-11-13 16:17:22 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-01-10 14:03:03 +0100
commiteedefb546af4744d9b21275403949afd1d21996b (patch)
tree0239b23e67f3921c7338dfe99a865872237970ae
parentmedia-libs/opencv: 4.8.0-r1 drop broken protobuf patch (diff)
downloadgentoo-eedefb546af4744d9b21275403949afd1d21996b.tar.gz
gentoo-eedefb546af4744d9b21275403949afd1d21996b.tar.bz2
gentoo-eedefb546af4744d9b21275403949afd1d21996b.zip
sci-mathematics/geogebra-bin: add 6.0.804.0
Closes: https://bugs.gentoo.org/900973 Signed-off-by: Henri Gasc <gasc@eurecom.fr> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--sci-mathematics/geogebra-bin/Manifest1
-rw-r--r--sci-mathematics/geogebra-bin/geogebra-bin-6.0.804.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/sci-mathematics/geogebra-bin/Manifest b/sci-mathematics/geogebra-bin/Manifest
index 113ec2e8cb4f..61034f29c9c1 100644
--- a/sci-mathematics/geogebra-bin/Manifest
+++ b/sci-mathematics/geogebra-bin/Manifest
@@ -1,2 +1,3 @@
DIST GeoGebra-Linux-Portable-5-0-752-0.tar.bz2 131020013 BLAKE2B f29b301d163daf9af62a4230ff3170eca2b61c20a2b41f851af4571db03487a0fd87cc178fad83d83c5268d9c22a1e47529b80f3067debc846c158bff4f78d1b SHA512 0c4fa07cdbccf0b7529726e1ee921bd6a461645a27012ac4b2e3140f3a4b068f2a9c929e1136a1c10cd510c8acbc5b1f38b735d9386d357b52b41f0a37e93acf
+DIST GeoGebra-Linux64-Portable-6-0-804-0.zip 111009113 BLAKE2B efa8468fede7d0ad1751ead765f44d120e45fb3ff1738f267518bb7594494252ded7bd2a2f7476e938e035c0ccc55fcee38853042cc150b92ea05a64e541fbc6 SHA512 4ef0d3aaaed396c9ce934638f52b148c5e2c1bcd5a5a12aefa7250982030d16e23ccc33c1623807d8910c1360efbb2115af3e2552679576c0ebdb07afb5c031c
DIST Geogebra.svg 522 BLAKE2B 8c11d037bd8af7af571abc2bba0a8610f0ed5c1cea46fdc47a40d0176e5ea3b7ad4700601a3094b1aa15012f769883c7f5cb60a70f4ed400df57e3b0610271e9 SHA512 a54fedd530d1c803e14d6f44ab7341d9f1ae17fb6b6496bd21788ad1b88b0977d574db6de199e9168543a03dff73ab19e3c50793ec91750ff5fff4a4b7af408d
diff --git a/sci-mathematics/geogebra-bin/geogebra-bin-6.0.804.0.ebuild b/sci-mathematics/geogebra-bin/geogebra-bin-6.0.804.0.ebuild
new file mode 100644
index 000000000000..b9904d359613
--- /dev/null
+++ b/sci-mathematics/geogebra-bin/geogebra-bin-6.0.804.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg
+
+MY_PV="${PV//./-}"
+
+DESCRIPTION="Mathematics software for geometry"
+HOMEPAGE="https://www.geogebra.org"
+SRC_URI="https://download.geogebra.org/installers/$(ver_cut 1-2)/GeoGebra-Linux64-Portable-${MY_PV}.zip
+ https://dev.gentoo.org/~gyakovlev/distfiles/Geogebra.svg"
+
+LICENSE="Geogebra CC-BY-NC-SA-3.0 GPL-3 Apache-2.0 BSD-2 BSD BSD-4 colt EPL-1.0 icu LGPL-2.1 LGPL-2.1+ MIT W3C || ( GPL-2 CDDL )"
+SLOT="0"
+KEYWORDS="~amd64 -*"
+
+RDEPEND="
+ x11-libs/libxshmfence
+ dev-libs/nss
+ app-accessibility/at-spi2-core
+ x11-libs/libdrm
+ >=x11-libs/gtk+-3
+ media-libs/alsa-lib
+ net-print/cups
+"
+BDEPEND="
+ app-arch/unzip
+ media-libs/libpng
+"
+DEPEND="${RDEPEND}"
+
+# no tests
+RESTRICT="test"
+
+QA_PREBUILT="*"
+
+src_unpack() {
+ default
+ mv -v GeoGebra-linux-x64 "${P}" || die
+}
+
+src_install() {
+ # Fix PNGs
+ png_path="${S}/resources/app/node_modules/ref-napi/docs/images"
+ pngfix --out=out.png "${png_path}/apple-touch-icon.png"
+ mv -f out.png "${png_path}/apple-touch-icon.png" || die
+ pngfix --out=out.png "${png_path}/apple-touch-icon-72x72.png"
+ mv -f out.png "${png_path}/apple-touch-icon-72x72.png" || die
+ pngfix --out=out.png "${png_path}/apple-touch-icon-114x114.png"
+ mv -f out.png "${png_path}/apple-touch-icon-114x114.png" || die
+
+ rm -r "${S}/resources/app/node_modules/ref-napi/prebuilds/linux-arm64"
+ rm -r "${S}/resources/app/node_modules/ffi-napi/prebuilds/linux-arm64"
+
+ insinto /opt/GeoGebra
+ doins -r .
+
+ dosym -r /opt/GeoGebra/GeoGebra /usr/bin/geogebra
+ fperms 0755 /opt/GeoGebra/GeoGebra
+ doicon "${DISTDIR}/Geogebra.svg"
+ make_desktop_entry geogebra Geogebra Geogebra Science
+}
+
+src_test() {
+ ewarn "package has no tests"
+}