summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-02 06:43:13 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-02 06:44:25 +0100
commitef5c6301fe39b1ffce42004ad20dec275a49482c (patch)
tree5cb44f10e0b63977fca89f287e15acff4a1b677a
parentdev-python/tempest: Remove old (diff)
downloadgentoo-ef5c6301fe39b1ffce42004ad20dec275a49482c.tar.gz
gentoo-ef5c6301fe39b1ffce42004ad20dec275a49482c.tar.bz2
gentoo-ef5c6301fe39b1ffce42004ad20dec275a49482c.zip
dev-python/seaborn: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/seaborn/Manifest1
-rw-r--r--dev-python/seaborn/files/seaborn-0.12.2-matplotlib-3.7.patch19
-rw-r--r--dev-python/seaborn/seaborn-0.12.2.ebuild44
3 files changed, 0 insertions, 64 deletions
diff --git a/dev-python/seaborn/Manifest b/dev-python/seaborn/Manifest
index 986bdede51e9..893779dfa24f 100644
--- a/dev-python/seaborn/Manifest
+++ b/dev-python/seaborn/Manifest
@@ -1,2 +1 @@
-DIST seaborn-0.12.2.tar.gz 1439798 BLAKE2B cf6903b1a2d27516bcafe46cabc81ea9fac80666394a6a82516630f9ac60afc7e9d31817e029cda9a08da04c0a37ce0244ad23acda16bca3283532ddb0fbdb71 SHA512 988a9922ee301b655911efa38905674b7dd15e7f7b157ad67f5befaeb02db492553f8bd6133b54d2dd7970b8dbbfd92d81d1faea3fa618247ebcaeb98620a060
DIST seaborn-0.13.0.tar.gz 1455480 BLAKE2B 9f7383715366889ffd80788f901c574d9330285da2098e5695e944f1c6b92d4e417163a82378dd75c03233fc6485158401a1aaa461f2fa8e71a4cbc3ebf957cb SHA512 d603e880c29e05ab68f86d285c5c5ee9cf2da1d45265ed609f7bc87650fe20e80c026af487f63f9492a268f51ba5bab0cae4fd8fdeaf28125d16d317f9c937c8
diff --git a/dev-python/seaborn/files/seaborn-0.12.2-matplotlib-3.7.patch b/dev-python/seaborn/files/seaborn-0.12.2-matplotlib-3.7.patch
deleted file mode 100644
index dbc4908321d9..000000000000
--- a/dev-python/seaborn/files/seaborn-0.12.2-matplotlib-3.7.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-https://github.com/mwaskom/seaborn/commit/db7ae11750fc2dfb695457239708448d54e9b8cd
-
-From db7ae11750fc2dfb695457239708448d54e9b8cd Mon Sep 17 00:00:00 2001
-From: Michael Waskom <mwaskom@users.noreply.github.com>
-Date: Wed, 25 Jan 2023 16:58:26 -0500
-Subject: [PATCH] Update test to reflect change in matplotlib 3.7 (#3236)
-
---- a/tests/test_axisgrid.py
-+++ b/tests/test_axisgrid.py
-@@ -331,7 +331,7 @@ def test_subplot_kws(self):
- g = ag.FacetGrid(self.df, despine=False,
- subplot_kws=dict(projection="polar"))
- for ax in g.axes.flat:
-- assert "PolarAxesSubplot" in str(type(ax))
-+ assert "PolarAxes" in ax.__class__.__name__
-
- def test_gridspec_kws(self):
- ratios = [3, 1, 2]
-
diff --git a/dev-python/seaborn/seaborn-0.12.2.ebuild b/dev-python/seaborn/seaborn-0.12.2.ebuild
deleted file mode 100644
index f6dc1cf23fc6..000000000000
--- a/dev-python/seaborn/seaborn-0.12.2.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{9..11} )
-inherit distutils-r1 multiprocessing pypi
-
-DESCRIPTION="Statistical data visualization"
-HOMEPAGE="https://seaborn.pydata.org https://github.com/mwaskom/seaborn"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/statsmodels[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? ( dev-python/pytest-xdist[${PYTHON_USEDEP}] )
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-matplotlib-3.7.patch
-)
-
-distutils_enable_tests pytest
-
-src_test() {
- cat > matplotlibrc <<- EOF || die
- backend : Agg
- EOF
-
- distutils-r1_src_test
-}
-
-python_test() {
- epytest -n "$(makeopts_jobs)"
-}