summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2023-09-09 05:15:42 +0300
committerBen Kohler <bkohler@gentoo.org>2023-10-02 09:47:42 -0500
commitf16a213c274bd20dce5a6482df9ba1c33937e0fc (patch)
tree15dc9ea9bcd0d1eef544c424f4d9084fd627e582
parentnet-wireless/kismet: 2023.07.1 build fix (diff)
downloadgentoo-f16a213c274bd20dce5a6482df9ba1c33937e0fc.tar.gz
gentoo-f16a213c274bd20dce5a6482df9ba1c33937e0fc.tar.bz2
gentoo-f16a213c274bd20dce5a6482df9ba1c33937e0fc.zip
sys-apps/hwinfo: add 23.2
Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32698 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
-rw-r--r--sys-apps/hwinfo/Manifest1
-rw-r--r--sys-apps/hwinfo/hwinfo-23.2.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/sys-apps/hwinfo/Manifest b/sys-apps/hwinfo/Manifest
index a045901b9888..7f4845b30d16 100644
--- a/sys-apps/hwinfo/Manifest
+++ b/sys-apps/hwinfo/Manifest
@@ -1,2 +1,3 @@
DIST hwinfo-22.2-1.2.src.rpm 1063515 BLAKE2B 4baede16a2528421df77de2d6547f7301db8545de712327dc96a435819d2a35bac7d7ddd3bac5b0758d947ceb0360cb09d640154f392a844e8e201339781f4ed SHA512 76384ca7bce779ca92cd17f5312546ca6ff1ffd93be9d35253e65d1efda03bb8d596e89776024a51f9874c57cf2852938fb85c1f5b745d898e0bafe10cdbbdf9
DIST hwinfo-23.1-1.1.src.rpm 1064746 BLAKE2B 59b3bac5dd8188abfec76a6f86bf0f9cbab5922900681d987ce3728911065331f730314df23d53dbd08992b4d67d7431b6f9566dcefa574b09956e41ccc8dfb0 SHA512 51622e3fff885e83b4f143e1f029915fb4a29b2a4b35d618945dfa8638a36e7e51c0b2edf51ad091a17a2599fd850cbc90c4d744889fcf375a9a7c5683966bdd
+DIST hwinfo-23.2.tar.gz 1237565 BLAKE2B 86c085c0b58b967f94ded3db4975cd824f69908b3b7fc1d27e2d51cb0e570969a7af2274f55d6eb1d871e1422016deb8007c76199be441ad94486ab18f9bff7a SHA512 86096455cc58ecdd3be4306d61beaea02da39b8ee3b2a99966d4aaf022e276616329ca82550d7903e2aed9b1723a99b2305617fb85df21c1d2024ce46b447af3
diff --git a/sys-apps/hwinfo/hwinfo-23.2.ebuild b/sys-apps/hwinfo/hwinfo-23.2.ebuild
new file mode 100644
index 000000000000..ef462e9dc064
--- /dev/null
+++ b/sys-apps/hwinfo/hwinfo-23.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Hardware detection tool used in SuSE Linux"
+HOMEPAGE="https://github.com/openSUSE/hwinfo/"
+SRC_URI="https://github.com/openSUSE/hwinfo/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="amd64? ( dev-libs/libx86emu )
+ x86? ( dev-libs/libx86emu )"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.17"
+BDEPEND="sys-devel/flex"
+
+src_prepare() {
+ default
+ # Respect AR variable.
+ sed -i \
+ -e 's:ar r:$(AR) r:' \
+ src/{,isdn,ids,smp,hd}/Makefile || die
+
+ # Respect LDFLAGS.
+ sed -i -e 's:$(CC) $(CFLAGS):$(CC) $(LDFLAGS) $(CFLAGS):' src/ids/Makefile || die
+
+ # Respect MAKE variable. Skip forced -pipe and -g.
+ sed -i \
+ -e 's:make:$(MAKE):' \
+ -e 's:-pipe -g::' \
+ Makefile{,.common} || die
+ rm -f git2log || die
+}
+
+src_compile() {
+ emake -j1 AR="$(tc-getAR)" CC="$(tc-getCC)" HWINFO_VERSION="${PV}" \
+ RPM_OPT_FLAGS="${CFLAGS}" LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" LIBDIR="/usr/$(get_libdir)" install
+ keepdir /var/lib/hardware/udi
+
+ dodoc README*
+ docinto examples
+ dodoc doc/example*.c
+ doman doc/*.{1,8}
+}