summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2021-09-23 22:38:12 +0200
committerSebastian Pipping <sping@gentoo.org>2021-09-23 22:39:00 +0200
commitf36ba797c525a195bf8aac0ab2ec2da4f56cbe47 (patch)
treec0dddd4a34b2866f811f1669c1c1cd596cd5c1b7
parentapp-portage/metagen: py3.10 + DISTUTILS_USE_SETUPTOOLS (diff)
downloadgentoo-f36ba797c525a195bf8aac0ab2ec2da4f56cbe47.tar.gz
gentoo-f36ba797c525a195bf8aac0ab2ec2da4f56cbe47.tar.bz2
gentoo-f36ba797c525a195bf8aac0ab2ec2da4f56cbe47.zip
app-portage/fetchcommandwrapper: py3.10 + DISTUTILS_USE_SETUPTOOLS
Closes: https://bugs.gentoo.org/814230 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.23, Repoman-3.0.3
-rw-r--r--app-portage/fetchcommandwrapper/fetchcommandwrapper-0.8.4-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-portage/fetchcommandwrapper/fetchcommandwrapper-0.8.4-r2.ebuild b/app-portage/fetchcommandwrapper/fetchcommandwrapper-0.8.4-r2.ebuild
new file mode 100644
index 000000000000..6da2655d1d54
--- /dev/null
+++ b/app-portage/fetchcommandwrapper/fetchcommandwrapper-0.8.4-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Wrapper integrating aria2 into portage's FETCHCOMMAND"
+HOMEPAGE="https://github.com/hartwork/fetchcommandwrapper"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=net-misc/aria2-1.10.2[metalink,xmlrpc]"
+
+pkg_postinst() {
+ ewarn 'You need to append'
+ ewarn ' source /usr/share/fetchcommandwrapper/make.conf'
+ ewarn 'to /etc/portage/make.conf in order to integrate fetchcommandwrapper.'
+}