summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2023-07-06 15:14:04 +0200
committerAgostino Sarubbo <ago@gentoo.org>2023-07-06 15:14:04 +0200
commitf3701e401d3efa7e5ee49fc59bcc002141928c44 (patch)
treeb6dd4f76f9399afac65894ae61f80a5611ca9f86
parentsys-kernel/gentoo-kernel-bin: Bump to 5.15.120 (diff)
downloadgentoo-f3701e401d3efa7e5ee49fc59bcc002141928c44.tar.gz
gentoo-f3701e401d3efa7e5ee49fc59bcc002141928c44.tar.bz2
gentoo-f3701e401d3efa7e5ee49fc59bcc002141928c44.zip
dev-db/pg_activity: version bump to 3.4.2
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
-rw-r--r--dev-db/pg_activity/Manifest1
-rw-r--r--dev-db/pg_activity/pg_activity-3.4.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-db/pg_activity/Manifest b/dev-db/pg_activity/Manifest
index a3d5b0d51ca8..c5b1c42e92d8 100644
--- a/dev-db/pg_activity/Manifest
+++ b/dev-db/pg_activity/Manifest
@@ -1 +1,2 @@
DIST pg_activity-3.3.0.tar.gz 429012 BLAKE2B cc7a985c49713822ca0a250d6843820033e0ddac95429b5fbbb72e8beb6a6994020e6f2bdc0890341e72ad615d7da795e7411a817f5c25d275413852175f32b0 SHA512 94ffb48c5989fd47420c65c564a12fa0c2df7527e56c2832d00b04ed7fa75de77f3fce2c45e17435a4eecfd942665fa837147962fe695308455efb28c75cb5fc
+DIST pg_activity-3.4.2.tar.gz 432160 BLAKE2B 3f9a54a9f58c2d107e01e15aad1e8bb58c2df589cb8f0d58288636c16adfad2156f2c140506dc15bd6eb26a75a441afbf9db8a2db0766a17867fd5b8ed50b9bc SHA512 adcc12277341c60a8959103c30d38bdc76d2315130f1bb92239e5c2c8d20f8fc4a786be3fe1f97e3c142e6c74303a631017e1a3e6feaf18266b7fd42c2e155f3
diff --git a/dev-db/pg_activity/pg_activity-3.4.2.ebuild b/dev-db/pg_activity/pg_activity-3.4.2.ebuild
new file mode 100644
index 000000000000..bb4c7b32493d
--- /dev/null
+++ b/dev-db/pg_activity/pg_activity-3.4.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Realtime PostgreSQL database server monitoring tool"
+HOMEPAGE="https://github.com/dalibo/pg_activity"
+SRC_URI="https://github.com/dalibo/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+SLOT="0"
+LICENSE="POSTGRESQL"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/blessed[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/psycopg:0[${PYTHON_USEDEP}]
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # https://github.com/dalibo/pg_activity/issues/201
+ export COLUMNS="80"
+ epytest -k 'not test_ui.txt and not test_data.py'
+}
+
+src_install() {
+ distutils-r1_src_install
+ doman docs/man/${PN}.1
+}