summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-02-22 14:21:05 +0100
committerUlrich Müller <ulm@gentoo.org>2018-03-11 13:02:37 +0100
commitf40ffc42c1381cd29aa3b75b5d0c3c1372b175c5 (patch)
tree78f90052519946b420051778cb31233f479ccf7b
parentnet-misc/keychain: stable 2.8.5 for ia64, bug #650166 (diff)
downloadgentoo-f40ffc42c1381cd29aa3b75b5d0c3c1372b175c5.tar.gz
gentoo-f40ffc42c1381cd29aa3b75b5d0c3c1372b175c5.tar.bz2
gentoo-f40ffc42c1381cd29aa3b75b5d0c3c1372b175c5.zip
app-editors/emacs: Disable the sandbox only when dumping.
Apply this also to slots 18, 23, and 24. Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--app-editors/emacs/emacs-18.59-r11.ebuild13
-rw-r--r--app-editors/emacs/emacs-23.4-r17.ebuild5
-rw-r--r--app-editors/emacs/emacs-24.5-r5.ebuild4
3 files changed, 15 insertions, 7 deletions
diff --git a/app-editors/emacs/emacs-18.59-r11.ebuild b/app-editors/emacs/emacs-18.59-r11.ebuild
index 8b9d3d2c04e9..9b260064e0b8 100644
--- a/app-editors/emacs/emacs-18.59-r11.ebuild
+++ b/app-editors/emacs/emacs-18.59-r11.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -28,6 +28,14 @@ DEPEND="${RDEPEND}
PATCHES="../${P}-linux22x-elf-glibc21.diff ../patch"
+src_prepare() {
+ default
+
+ # Do not use the sandbox, or the dumped Emacs will be twice as large
+ sed -i -e 's:\./temacs.*dump:env SANDBOX_ON=0 LD_PRELOAD= &:' \
+ src/ymakefile || die
+}
+
src_configure() {
# autoconf? What's autoconf? We are living in 1992. ;-)
local arch
@@ -70,8 +78,7 @@ src_configure() {
}
src_compile() {
- # Do not use the sandbox, or the dumped Emacs will be twice as large
- export SANDBOX_ON=0
+ addpredict /var/lib/emacs/lock
emake --jobs=1 \
CC="$(tc-getCC)" CFLAGS="${CFLAGS} -Demacs" \
LD="$(tc-getCC) -nostdlib" LDFLAGS="${LDFLAGS}"
diff --git a/app-editors/emacs/emacs-23.4-r17.ebuild b/app-editors/emacs/emacs-23.4-r17.ebuild
index 92884cb78c16..b331aae1a49c 100644
--- a/app-editors/emacs/emacs-23.4-r17.ebuild
+++ b/app-editors/emacs/emacs-23.4-r17.ebuild
@@ -223,10 +223,11 @@ src_configure() {
}
src_compile() {
- export SANDBOX_ON=0 # for the unbelievers, see Bug #131505
+ # Disable sandbox when dumping. For the unbelievers, see bug #131505
emake CC="$(tc-getCC)" \
AR="$(tc-getAR) cq" \
- RANLIB="$(tc-getRANLIB)"
+ RANLIB="$(tc-getRANLIB)" \
+ RUN_TEMACS="env SANDBOX_ON=0 LD_PRELOAD= ./temacs"
}
src_install () {
diff --git a/app-editors/emacs/emacs-24.5-r5.ebuild b/app-editors/emacs/emacs-24.5-r5.ebuild
index cc5f76a02d49..2668c7388bd9 100644
--- a/app-editors/emacs/emacs-24.5-r5.ebuild
+++ b/app-editors/emacs/emacs-24.5-r5.ebuild
@@ -224,8 +224,8 @@ src_configure() {
}
src_compile() {
- export SANDBOX_ON=0 # for the unbelievers, see Bug #131505
- emake
+ # Disable sandbox when dumping. For the unbelievers, see bug #131505
+ emake RUN_TEMACS="env SANDBOX_ON=0 LD_PRELOAD= ./temacs"
}
src_install () {