summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2017-07-06 20:16:15 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2017-07-06 20:16:15 -0400
commitf41afad6822183065630f8accc9a27213ee6b543 (patch)
tree50b653db8fd4c986dba98f979ad05c6157b73f10
parentdev-python/pytest-isort: Initial commit (diff)
downloadgentoo-f41afad6822183065630f8accc9a27213ee6b543.tar.gz
gentoo-f41afad6822183065630f8accc9a27213ee6b543.tar.bz2
gentoo-f41afad6822183065630f8accc9a27213ee6b543.zip
dev-python/tinycss2: Initial commit
Required by weasyprint. Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--dev-python/tinycss2/Manifest1
-rw-r--r--dev-python/tinycss2/metadata.xml16
-rw-r--r--dev-python/tinycss2/tinycss2-0.5.ebuild29
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/tinycss2/Manifest b/dev-python/tinycss2/Manifest
new file mode 100644
index 000000000000..1faaceefb592
--- /dev/null
+++ b/dev-python/tinycss2/Manifest
@@ -0,0 +1 @@
+DIST tinycss2-0.5.tar.gz 61802 SHA256 fea8a5100bf8a49f518113769cb22639f6de8bb1016e36616cea9812050e6919 SHA512 321af21a80dbdf8d1ad218e33c87edbe7c0b4c1bffeeb38a9b14bed9064749f71636bf70775186e8785587d5fa96e3488465a76b59f643658f84b6bdc1c5c4bd WHIRLPOOL fd7835c51df42da3052cd7605dc4970fd36dcb919a24b067d7eff99c60890e43abda949a2c8c6b5d32115f893579c6e5a0701c8931a21d7444b3734fd936ec06
diff --git a/dev-python/tinycss2/metadata.xml b/dev-python/tinycss2/metadata.xml
new file mode 100644
index 000000000000..95e6d41f324f
--- /dev/null
+++ b/dev-python/tinycss2/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>titanofold@gentoo.org</email>
+ <name>Aaron W. Swenson</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">tinycss2</remote-id>
+ <remote-id type="github">SimonSapin/tinycss2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/tinycss2/tinycss2-0.5.ebuild b/dev-python/tinycss2/tinycss2-0.5.ebuild
new file mode 100644
index 000000000000..aa53bc12e101
--- /dev/null
+++ b/dev-python/tinycss2/tinycss2-0.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A complete yet simple CSS parser for Python"
+HOMEPAGE="https://github.com/SimonSapin/tinycss2/ http://pypi.python.org/pypi/tinycss2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RESTRICT="test"
+
+RDEPEND="dev-python/webencodings[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+DOCS=( CHANGES README.rst )
+
+python_test() {
+ py.test || die "testsuite failed under ${EPYTHON}"
+}