summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-02-09 01:55:40 -0500
committerTim Harder <radhermit@gentoo.org>2018-02-09 02:03:55 -0500
commitf43c706eea984eb94cf2d71544da140e1a610bf5 (patch)
tree7b1d982bf0d6a1d18cb7a1d5624445919c757545
parentdev-ruby/ritex: add ruby25 (diff)
downloadgentoo-f43c706eea984eb94cf2d71544da140e1a610bf5.tar.gz
gentoo-f43c706eea984eb94cf2d71544da140e1a610bf5.tar.bz2
gentoo-f43c706eea984eb94cf2d71544da140e1a610bf5.zip
dev-python/hypothesis: version bump to 3.44.26
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-3.44.26.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 436783fd81b5..e384123d59d1 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,3 +1,4 @@
DIST hypothesis-3.38.5.tar.gz 474087 BLAKE2B a3182701463e03383cf4d5fb16605d494c5339a23ea77d789d27eaaf576ee3c2c81a7ebfcb4641b15b9c19755d85a6f0d36555f8091bef8986e8afb290eedc85 SHA512 bd13bda0adf2fc1629c41c6b5b63744f1b33b0b9cfbcd4b78c73b8ab9cde2db50e2c084216c4123f93efc2355d4d45d3d6e51b079d8722341deb5df24fedf6b1
+DIST hypothesis-3.44.26.tar.gz 420980 BLAKE2B 436dc5b0388188122a9327457f8009fea318a4690bffd6e56717750409fbd79e2566ea820ba542c12ff1f04fc358ee36f8c98e72fe6f9efba90d25168c823208 SHA512 59ea34951802cf57f14512c6698ca1169ee3424d3edfe76843fce4a5b691580d57aaa850322318b7ed98025f779b264e9a5f43ab345a1ae633be0ec45aa631ad
DIST hypothesis-3.44.7.tar.gz 403113 BLAKE2B a929322db86a9f769dff43c668609ad18407d1e3456cb1b0057f846d1e3c807f1198f23d6a182b48fc39b2e716780d07433cfffbc636de9b9456e4f335e07b60 SHA512 07c21480457c70c2d57e7036296a4c2c418f0380608f28790f7c2269d003b227a2038fbac8b8370e3178bb77fea8ce2e13bb6f14296486ea6eae2fdef5870567
DIST hypothesis-3.6.0.tar.gz 73586 BLAKE2B b0ec133e8c71f752114211061155c15a7d536e771ba85eab6489440b2063d3083018bf8502d9e9dbc73105ee5f03060e3189e64574a3dfa052b091040e7e7915 SHA512 cb885628e5c38ab9312cfb177ebc3c014617d21031737f5fba343ba485c1b8ff82b1302e7bc1d3e79192bfd8324fd0501498c968f3ac8343829f8965f6354389
diff --git a/dev-python/hypothesis/hypothesis-3.44.26.ebuild b/dev-python/hypothesis/hypothesis-3.44.26.ebuild
new file mode 100644
index 000000000000..1ac95341c108
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-3.44.26.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis-python https://pypi.python.org/pypi/hypothesis"
+SRC_URI="https://github.com/HypothesisWorks/hypothesis-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2*' pypy)"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${PN}-python-${PV}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pytest support" dev-python/pytest
+}