summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-07 03:55:38 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-07 05:14:57 +0200
commitf4a02195d79dbfbb5665aba30ce56a044365e84e (patch)
treecdb11e68b622fa0a1b63ee5b17bd3c61592552fd
parentdev-python/platformdirs: Bump to 3.8.1 (diff)
downloadgentoo-f4a02195d79dbfbb5665aba30ce56a044365e84e.tar.gz
gentoo-f4a02195d79dbfbb5665aba30ce56a044365e84e.tar.bz2
gentoo-f4a02195d79dbfbb5665aba30ce56a044365e84e.zip
dev-python/click: Bump to 8.1.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/click/Manifest1
-rw-r--r--dev-python/click/click-8.1.4.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/click/Manifest b/dev-python/click/Manifest
index a1471fcfb1f5..32715b81fc85 100644
--- a/dev-python/click/Manifest
+++ b/dev-python/click/Manifest
@@ -1 +1,2 @@
DIST click-8.1.3.gh.tar.gz 333961 BLAKE2B ed80d9be1e5740f1e4af62e97cd78488dc99d59da4a6dc9c99fb62b08c32ca2b889e3678a2841052922d102d8ac83df19e3e2d0ff41c46387e695d3718c7702d SHA512 29194ee3877e013a2fe1037870522c5b5a78136ca60da9109f29312a3e52c767867f5eec2d90ca385cd0508f77555b9d6ad8f5141dc31900ddc9307a2207a818
+DIST click-8.1.4.gh.tar.gz 340493 BLAKE2B 953e4033a1715ec631bec197f62d1015de28579e0cf3c3ee8fab1941a60797130d12e752aea5dc210cbedea1735cc6fa517eaf9f88836599a9135f42368bb603 SHA512 3095990cdbaa01a61fa5d84f6a80c03a9c645c81ac569f66a4b23ba06e37ba79a5c9fcc6f09a7b8bed1082cb17c0381743c5a160ae14634f102b7f29175e739b
diff --git a/dev-python/click/click-8.1.4.ebuild b/dev-python/click/click-8.1.4.ebuild
new file mode 100644
index 000000000000..0cf462f36528
--- /dev/null
+++ b/dev-python/click/click-8.1.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package for creating beautiful command line interfaces"
+HOMEPAGE="
+ https://palletsprojects.com/p/click/
+ https://github.com/pallets/click/
+ https://pypi.org/project/click/
+"
+SRC_URI="
+ https://github.com/pallets/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="examples"
+
+distutils_enable_sphinx docs \
+ '>=dev-python/docutils-0.14' \
+ dev-python/pallets-sphinx-themes \
+ dev-python/sphinxcontrib-log-cabinet \
+ dev-python/sphinx-issues \
+ dev-python/sphinx-tabs
+distutils_enable_tests pytest
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}