summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-03-24 13:13:04 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-03-24 14:37:34 -0400
commitf4f5384a31752bfbaf021725ac539d1522656423 (patch)
tree634664dbc5d2ab7538389744d8fbbe60be6ff092
parentdev-qt/qtbase: drop 6.7.0_rc (diff)
downloadgentoo-f4f5384a31752bfbaf021725ac539d1522656423.tar.gz
gentoo-f4f5384a31752bfbaf021725ac539d1522656423.tar.bz2
gentoo-f4f5384a31752bfbaf021725ac539d1522656423.zip
dev-util/mingw64-toolchain: filter -Wl,-z,* ... for CFLAGS
strip-unsupported-flags handles this fine in LDFLAGS, but -Wl,* are no-ops during compile-only tests (thus not stripped) and then if a package compiles and links anything at same time it fails. This used not to be a big problem but now that 23.0 profiles do -Wl,-z,pack-relative-relocs (mingw ld has no -z) this is hitting bashrc-mv users that tend to do CFLAGS="${LDFLAGS}" by default. Tempting to ignore it because of how wrong it is, but well. An alternate route could be to eventually have strip-flags and/or strip-unsupported-flags remove -Wl,* from non-LDFLAGS given this could affect more than mingw (e.g. switching to bfd when there is a lld-only option). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0_p2.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0_p2.ebuild b/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0_p2.ebuild
index 9aab786878f3..910dddbdfbb5 100644
--- a/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0_p2.ebuild
+++ b/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0_p2.ebuild
@@ -211,6 +211,11 @@ src_compile() {
filter-flags '-fuse-ld=*'
filter-flags '-mfunction-return=thunk*' #878849
+ # some bashrc-mv users tend to do CFLAGS="${LDFLAGS}" and then
+ # strip-unsupported-flags miss these during compile-only tests
+ # (primarily done for 23.0 profiles' -z, not full coverage)
+ filter-flags '-Wl,-z,*'
+
# -mavx with mingw-gcc has a history of obscure issues and
# disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
# crashes with -march=skylake >=wine-8.10, similar issues with