summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-07-28 06:33:34 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-07-28 10:47:24 -0400
commitf81003f4fb36e13db393c29cead0a67d2f3cbc02 (patch)
tree4d623b436e846e4f05c8a4d191360c3e18e075cf
parentdev-python/apsw: Enable py3.12 (diff)
downloadgentoo-f81003f4fb36e13db393c29cead0a67d2f3cbc02.tar.gz
gentoo-f81003f4fb36e13db393c29cead0a67d2f3cbc02.tar.bz2
gentoo-f81003f4fb36e13db393c29cead0a67d2f3cbc02.zip
app-emulation/ruffle: always skip renderer tests
Too volatile, hopefully should be the last see of these. Also drop virtualx at same time, not that it was needed (anymore) even for renderer tests given upstream fixed usage with headless. Bug: https://bugs.gentoo.org/911320 Close: https://bugs.gentoo.org/911367 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--app-emulation/ruffle/files/ruffle-0_p20230724-skip-render-tests.patch16
-rw-r--r--app-emulation/ruffle/ruffle-0_p20230724.ebuild25
-rw-r--r--app-emulation/ruffle/ruffle-9999.ebuild25
3 files changed, 30 insertions, 36 deletions
diff --git a/app-emulation/ruffle/files/ruffle-0_p20230724-skip-render-tests.patch b/app-emulation/ruffle/files/ruffle-0_p20230724-skip-render-tests.patch
new file mode 100644
index 000000000000..46b66538aac8
--- /dev/null
+++ b/app-emulation/ruffle/files/ruffle-0_p20230724-skip-render-tests.patch
@@ -0,0 +1,16 @@
+Running renderer tests using mesa's software rendering has a tendency
+to misbehave (esp. on tinderboxes) and does not reflect usage on real
+hardware.
+
+These are auto-skipped if mesa[-gles2] and perhaps [-llvm], but pretend
+we lack support even if conditions are met.
+
+https://bugs.gentoo.org/903295
+https://bugs.gentoo.org/911320
+https://bugs.gentoo.org/911367
+--- a/tests/tests/util/options.rs
++++ b/tests/tests/util/options.rs
+@@ -163,2 +163,3 @@
+ if let Some(render) = &self.with_renderer {
++ if check_renderer { return false; }
+ // If we don't actually want to check the renderer (ie we're just listing potential tests),
diff --git a/app-emulation/ruffle/ruffle-0_p20230724.ebuild b/app-emulation/ruffle/ruffle-0_p20230724.ebuild
index 012ed52e5f0f..350e5cff76e1 100644
--- a/app-emulation/ruffle/ruffle-0_p20230724.ebuild
+++ b/app-emulation/ruffle/ruffle-0_p20230724.ebuild
@@ -550,7 +550,7 @@ declare -A GIT_CRATES=(
[nihav_core]="https://github.com/ruffle-rs/nihav-vp6;9416fcc9fc8aab8f4681aa9093b42922214abbd3;nihav-vp6-%commit%/nihav-core"
[nihav_duck]="https://github.com/ruffle-rs/nihav-vp6;9416fcc9fc8aab8f4681aa9093b42922214abbd3;nihav-vp6-%commit%/nihav-duck"
)
-inherit cargo desktop flag-o-matic virtualx xdg
+inherit cargo desktop flag-o-matic xdg
MY_PV="nightly-${PV:3:4}-${PV:7:2}-${PV:9:2}"
MY_P="${PN}-${MY_PV}"
@@ -571,6 +571,8 @@ LICENSE+="
" # crates
SLOT="0"
KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
# dlopen: libX* (see winit+x11-dl crates)
RDEPEND="
@@ -592,14 +594,14 @@ BDEPEND="
virtual/jre:*
virtual/pkgconfig
>=virtual/rust-1.70
- test? (
- media-libs/mesa[llvm]
- x11-base/xorg-server[-minimal]
- )
"
QA_FLAGS_IGNORED="usr/bin/${PN}.*"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0_p20230724-skip-render-tests.patch
+)
+
src_configure() {
filter-lto # TODO: cleanup after bug #893658
@@ -614,19 +616,6 @@ src_configure() {
cargo_src_configure ${workspaces[*]/#/--package=}
}
-src_test() {
- xdg_environment_reset
-
- local skip=(
- # this should be fine on real hardware, but currently fails with mesa's
- # software rendering (bug #911320) -- note they are auto-skipped if
- # USE=-gles2 on mesa, and this just forces to skip regardless
- --skip visual/filters/displacement_map
- )
-
- virtx cargo_src_test -- "${skip[@]}"
-}
-
src_install() {
dodoc README.md
diff --git a/app-emulation/ruffle/ruffle-9999.ebuild b/app-emulation/ruffle/ruffle-9999.ebuild
index ced4e9790b1e..fbc440002e65 100644
--- a/app-emulation/ruffle/ruffle-9999.ebuild
+++ b/app-emulation/ruffle/ruffle-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cargo desktop flag-o-matic git-r3 virtualx xdg
+inherit cargo desktop flag-o-matic git-r3 xdg
DESCRIPTION="Flash Player emulator written in Rust"
HOMEPAGE="https://ruffle.rs/"
@@ -16,6 +16,8 @@ LICENSE+="
Unicode-DFS-2016 ZLIB curl
" # crates
SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
# dlopen: libX* (see winit+x11-dl crates)
RDEPEND="
@@ -37,14 +39,14 @@ BDEPEND="
virtual/jre:*
virtual/pkgconfig
>=virtual/rust-1.70
- test? (
- media-libs/mesa[llvm]
- x11-base/xorg-server[-minimal]
- )
"
QA_FLAGS_IGNORED="usr/bin/${PN}.*"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0_p20230724-skip-render-tests.patch
+)
+
src_unpack() {
git-r3_src_unpack
@@ -79,19 +81,6 @@ src_configure() {
cargo_src_configure ${workspaces[*]/#/--package=}
}
-src_test() {
- xdg_environment_reset
-
- local skip=(
- # this should be fine on real hardware, but currently fails with mesa's
- # software rendering (bug #911320) -- note they are auto-skipped if
- # USE=-gles2 on mesa, and this just forces to skip regardless
- --skip visual/filters/displacement_map
- )
-
- virtx cargo_src_test -- "${skip[@]}"
-}
-
src_install() {
dodoc README.md