summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-06 08:28:04 +0000
committerSam James <sam@gentoo.org>2023-12-06 08:31:40 +0000
commitfa1593152d4a210b8ac3327557620746b6ddb152 (patch)
treea252ffe07eb019be907a8f98555c2f0418314dc2
parentmedia-video/mplayer: add 1.5_p20231206 (diff)
downloadgentoo-fa1593152d4a210b8ac3327557620746b6ddb152.tar.gz
gentoo-fa1593152d4a210b8ac3327557620746b6ddb152.tar.bz2
gentoo-fa1593152d4a210b8ac3327557620746b6ddb152.zip
media-video/mplayer: backport gcc-13 fix
The snapshot I just pushed (1.5_p20231206) will fix it for ~arch users, but let's backport this for stable. Bug: https://bugs.gentoo.org/918113 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-video/mplayer/files/mplayer-1.5_p20230618-gcc13.patch11
-rw-r--r--media-video/mplayer/mplayer-1.5_p20230618.ebuild4
2 files changed, 15 insertions, 0 deletions
diff --git a/media-video/mplayer/files/mplayer-1.5_p20230618-gcc13.patch b/media-video/mplayer/files/mplayer-1.5_p20230618-gcc13.patch
new file mode 100644
index 000000000000..0aab0273d424
--- /dev/null
+++ b/media-video/mplayer/files/mplayer-1.5_p20230618-gcc13.patch
@@ -0,0 +1,11 @@
+https://bugs.gentoo.org/918113
+--- a/libmpcodecs/mp_image.c
++++ b/libmpcodecs/mp_image.c
+@@ -30,6 +30,7 @@
+ #include "libmpcodecs/mp_image.h"
+ #include "libvo/fastmemcpy.h"
+ #include "libavutil/mem.h"
++#include <limits.h>
+ #include "mp_msg.h"
+
+ void mp_image_alloc_planes(mp_image_t *mpi) {
diff --git a/media-video/mplayer/mplayer-1.5_p20230618.ebuild b/media-video/mplayer/mplayer-1.5_p20230618.ebuild
index 3acf8571df98..9a7535cdde6b 100644
--- a/media-video/mplayer/mplayer-1.5_p20230618.ebuild
+++ b/media-video/mplayer/mplayer-1.5_p20230618.ebuild
@@ -194,6 +194,10 @@ REQUIRED_USE="
xv? ( X )"
RESTRICT="faac? ( bindist )"
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc13.patch
+)
+
pkg_setup() {
if [[ ${PV} == *9999* ]]; then
elog