summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-08-26 20:55:13 +0200
committerHans de Graaff <graaff@gentoo.org>2023-08-26 21:07:49 +0200
commitfbfc739419c39f8254057d49652507fc18ec6c4d (patch)
tree5aa18436e5fd3ca39c0b9b5cd9b80eeafb6473f4
parentdev-ruby/rantly: drop 2.0.0 (diff)
downloadgentoo-fbfc739419c39f8254057d49652507fc18ec6c4d.tar.gz
gentoo-fbfc739419c39f8254057d49652507fc18ec6c4d.tar.bz2
gentoo-fbfc739419c39f8254057d49652507fc18ec6c4d.zip
dev-ruby/pluggaloid: update EAPI 7 -> 8
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/pluggaloid/pluggaloid-1.7.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/pluggaloid/pluggaloid-1.7.0-r1.ebuild b/dev-ruby/pluggaloid/pluggaloid-1.7.0-r1.ebuild
new file mode 100644
index 000000000000..6195f7a62c4a
--- /dev/null
+++ b/dev-ruby/pluggaloid/pluggaloid-1.7.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+DESCRIPTION="Pluggaloid is extensible plugin system for mikutter"
+HOMEPAGE="https://rubygems.org/gems/pluggaloid/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/delayer-1.1.0:1
+ dev-ruby/instance_storage:0
+"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile test/*_test.rb || die
+}