summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-02-15 10:34:13 -0800
committerMatt Turner <mattst88@gentoo.org>2022-02-15 12:36:32 -0800
commitfcc37dfe73262f644f08ef258913da5f389bfd1a (patch)
tree8a3e830f4c458ce8761fa802c3f4501b816589c4
parentsys-apps/osinfo-db: Version bump to 20220214 (diff)
downloadgentoo-fcc37dfe73262f644f08ef258913da5f389bfd1a.tar.gz
gentoo-fcc37dfe73262f644f08ef258913da5f389bfd1a.tar.bz2
gentoo-fcc37dfe73262f644f08ef258913da5f389bfd1a.zip
sys-apps/osinfo-db-tools: Version bump to 1.10.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--sys-apps/osinfo-db-tools/Manifest1
-rw-r--r--sys-apps/osinfo-db-tools/osinfo-db-tools-1.10.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/sys-apps/osinfo-db-tools/Manifest b/sys-apps/osinfo-db-tools/Manifest
index bd723923223f..9d30c57119ab 100644
--- a/sys-apps/osinfo-db-tools/Manifest
+++ b/sys-apps/osinfo-db-tools/Manifest
@@ -1 +1,2 @@
+DIST osinfo-db-tools-1.10.0.tar.xz 60508 BLAKE2B 2b9abbdba25add96440e2a937ae994c0305f995b924ffc7c88c2c31c122d3e5cf0c710fbf55724bea56f63be7250321ee27d2179e3f247461d6843f7e03dfc58 SHA512 27271b15404a6cb0065854ba8556c272cf3427ff4fd18fc9a22dbca2b01686c32661b24e18f5eff9a1b240a3a459d8fe66cbde530873d60b8c850bdd0b42c475
DIST osinfo-db-tools-1.9.0.tar.xz 57704 BLAKE2B 43b25f9d3a32a4d22fb50874b8da5ffa2611b439213c4d41292f954b23515756558e4d6a5a56b53dc0f15a9abebc4f4b5dc08bf8fe9f77fc8c66d8c56ae96acd SHA512 516c57d47649d9425a54863e0050cccd9757caa710b7ef81b339bc75454c7b55bafe6623a69305f0fc3e47e5bcccfd05222475f8487e4a1b0c1588764c87a4e6
diff --git a/sys-apps/osinfo-db-tools/osinfo-db-tools-1.10.0.ebuild b/sys-apps/osinfo-db-tools/osinfo-db-tools-1.10.0.ebuild
new file mode 100644
index 000000000000..bb15268ef94c
--- /dev/null
+++ b/sys-apps/osinfo-db-tools/osinfo-db-tools-1.10.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit meson python-any-r1
+
+DESCRIPTION="Tools for managing the osinfo database"
+HOMEPAGE="https://libosinfo.org/"
+SRC_URI="https://releases.pagure.org/libosinfo/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ dev-libs/json-glib
+ >=app-arch/libarchive-3.0.0:=
+ net-libs/libsoup:2.4
+ >=dev-libs/libxml2-2.6.0
+"
+# perl dep is for pod2man (manpages)
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.19.8
+ dev-lang/perl
+ test? (
+ $(python_gen_any_dep '
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+python_check_deps() {
+ use test && \
+ has_version "dev-python/pytest[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/requests[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}