summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2023-04-29 18:12:08 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2023-04-29 18:12:33 +0200
commitfd5370b8f4ffd0cb119f07361b3ac1ad7817b278 (patch)
tree623fae39948b45a83d37eb9e732b2095f6ed760a
parentapp-arch/xz-utils: Stabilize 5.2.11 ppc64, #905288 (diff)
downloadgentoo-fd5370b8f4ffd0cb119f07361b3ac1ad7817b278.tar.gz
gentoo-fd5370b8f4ffd0cb119f07361b3ac1ad7817b278.tar.bz2
gentoo-fd5370b8f4ffd0cb119f07361b3ac1ad7817b278.zip
sci-visualization/gwyddion: add 2.62
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
-rw-r--r--sci-visualization/gwyddion/Manifest1
-rw-r--r--sci-visualization/gwyddion/gwyddion-2.62.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/sci-visualization/gwyddion/Manifest b/sci-visualization/gwyddion/Manifest
index 140a0b49ce44..53fcf98561ed 100644
--- a/sci-visualization/gwyddion/Manifest
+++ b/sci-visualization/gwyddion/Manifest
@@ -1 +1,2 @@
DIST gwyddion-2.61.tar.xz 4982092 BLAKE2B e4949558c52d2a6e97415b65e6816061c117868bdd2f39b341c3f740500f71dd38500323a389058b65f9c30feb9d5fd1e93bc29881b464cdb66981639fe280ed SHA512 c2fff49d52e4c439bf96e68be3534948c1fd48ade9b1e59e2d2d7d607170b5e7ce09e9cde3873ecca526de1561b028f39785dc363186f9f3d4ef0d259d313675
+DIST gwyddion-2.62.tar.xz 5010676 BLAKE2B 18012dfe050753413834e8a3734ec82989f375d81ac0242a6bbaf630da1a7741e9701d3c7a8c0dc03cfde8f93de9848ae106731f057c902f44ba1caf0cd79520 SHA512 93aff13f865fab045e17bd6c7633d714c4a97980ff10093f38c35e6dd39a0ed9680185f7a81a198522b623260cf6086d40e2b6a63a1cb59bc176eadf87fb85e1
diff --git a/sci-visualization/gwyddion/gwyddion-2.62.ebuild b/sci-visualization/gwyddion/gwyddion-2.62.ebuild
new file mode 100644
index 000000000000..28efdbfc583a
--- /dev/null
+++ b/sci-visualization/gwyddion/gwyddion-2.62.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools xdg
+
+DESCRIPTION="Framework for Scanning Mode Microscopy data analysis"
+HOMEPAGE="http://gwyddion.net/"
+SRC_URI="http://gwyddion.net/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="bzip2 doc fits jansson hdf5 nls openexr openmp perl ruby sourceview unique xml X zlib"
+
+RDEPEND="
+ >=dev-libs/glib-2.32
+ dev-libs/libzip
+ media-libs/libpng:0=
+ >=sci-libs/fftw-3.1:3.0=[openmp?]
+ virtual/libiconv
+ virtual/libintl
+ x11-libs/cairo
+ >=x11-libs/gtk+-2.18:2
+ x11-libs/libXmu
+ x11-libs/pango
+ bzip2? ( app-arch/bzip2 )
+ fits? ( sci-libs/cfitsio[bzip2?] )
+ jansson? ( dev-libs/jansson )
+ hdf5? ( sci-libs/hdf5[zlib?] )
+ openexr? ( media-libs/openexr:= )
+ perl? ( dev-lang/perl:= )
+ ruby? ( dev-ruby/narray )
+ unique? ( dev-libs/libunique:3 )
+ sourceview? ( x11-libs/gtksourceview:2.0 )
+ xml? ( dev-libs/libxml2:2 )
+ zlib? ( sys-libs/zlib )
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.60-automagic.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+# There are python bindings (--enable-pygwy) but they are py2 only
+# 3D opengl rendering requires deprecated GTK-2 x11-libs/gtkglext
+src_configure() {
+ # hack for bug 741840
+ use doc && export GTK_DOC_PATH=/usr/share/gtk-doc
+
+ econf \
+ --disable-rpath \
+ --without-kde4-thumbnailer \
+ $(use_enable doc gtk-doc) \
+ $(use_enable openmp) \
+ $(use_enable nls) \
+ --disable-pygwy \
+ --without-python \
+ $(use_with bzip2) \
+ $(use_with fits cfitsio) \
+ $(use_with hdf5) \
+ $(use_with jansson) \
+ $(use_with perl) \
+ $(use_with ruby) \
+ $(use_with openexr exr) \
+ --without-gl \
+ $(use_with sourceview gtksourceview) \
+ $(use_with unique) \
+ $(use_with xml libxml2) \
+ $(use_with X x) \
+ $(use_with zlib) \
+ --with-zip=libzip
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name "*.la" -delete || die
+}