summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 21:45:30 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:56:03 +0100
commitfdd150e5821b3dbfb2b5f8a323ef4bd654c44816 (patch)
treec0612f4ac00244a6794a0b555d4432161a099124
parentdev-python/python-sense-hat: drop 2.2.0-r2 (diff)
downloadgentoo-fdd150e5821b3dbfb2b5f8a323ef4bd654c44816.tar.gz
gentoo-fdd150e5821b3dbfb2b5f8a323ef4bd654c44816.tar.bz2
gentoo-fdd150e5821b3dbfb2b5f8a323ef4bd654c44816.zip
dev-util/smem: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-util/smem/smem-1.5-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/smem/smem-1.5-r2.ebuild b/dev-util/smem/smem-1.5-r2.ebuild
new file mode 100644
index 000000000000..a26a7477cdc1
--- /dev/null
+++ b/dev-util/smem/smem-1.5-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+EGIT_COMMIT="2ab5040d5633"
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit optfeature python-single-r1 toolchain-funcs
+
+DESCRIPTION="A tool that can give numerous reports on memory usage on Linux systems"
+HOMEPAGE="https://www.selenic.com/smem/"
+SRC_URI="https://selenic.com/repo/${PN}/archive/${EGIT_COMMIT}.tar.bz2 -> ${P}.tar.bz2"
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+BDEPEND="${RDEPEND}"
+
+src_compile() {
+ "$(tc-getCC)" ${CFLAGS} ${LDFLAGS} -o smemcap smemcap.c || die
+}
+
+src_install() {
+ dobin smemcap
+ python_doexe smem
+
+ doman smem.8
+}
+
+pkg_postinst() {
+ optfeature "for chart generation." dev-python/matplotlib
+}