summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-12-13 01:23:26 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-12-13 03:27:11 +0100
commitfeb6baf08a9e8c5add0704f76a352357c3afbd46 (patch)
tree3f812a134952e5287e5c8e1a009143c7bcf2ebeb
parentx11-wm/fvwm3: fix logic error (diff)
downloadgentoo-feb6baf08a9e8c5add0704f76a352357c3afbd46.tar.gz
gentoo-feb6baf08a9e8c5add0704f76a352357c3afbd46.tar.bz2
gentoo-feb6baf08a9e8c5add0704f76a352357c3afbd46.zip
dev-lang/dafny-bin: bump to 4.4.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-lang/dafny-bin/Manifest1
-rw-r--r--dev-lang/dafny-bin/dafny-bin-4.4.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-lang/dafny-bin/Manifest b/dev-lang/dafny-bin/Manifest
index 45119733bd18..068d19e51c16 100644
--- a/dev-lang/dafny-bin/Manifest
+++ b/dev-lang/dafny-bin/Manifest
@@ -1 +1,2 @@
DIST dafny-4.3.0-x64-ubuntu-20.04.zip 62691627 BLAKE2B edbff278472e5b0494fac38907adefa8fcfb94c3675df828e9ee022429d9595eed398d95333b223a70040ed69f07682e8aeaf90978f7466f4b9a412207d54d58 SHA512 14a861a6b0b55ee71db08f4c73e741fd92e5433d62411a2b17b177470b23148e288d835f80c2bdb388297f37be249b8a47bd3f83c2268082248f27d218b9cb9a
+DIST dafny-4.4.0-x64-ubuntu-20.04.zip 62873378 BLAKE2B ee471dfc0be515949bc3ec18cd46705ce35c7a0b43b8ffc35e7754cef57a3e9351b7e937b6735319d6255407b6cb46b4c0c69eab5a573fdf7671055efe3988b8 SHA512 acfd643bdf3dba7377fde8d36f3c7bfff27b575fbc212d02974958ad38fe433870128525ff22f9a76d4b1602d5253794409ce834b67c52571d395a737fc24471
diff --git a/dev-lang/dafny-bin/dafny-bin-4.4.0.ebuild b/dev-lang/dafny-bin/dafny-bin-4.4.0.ebuild
new file mode 100644
index 000000000000..0f5cd85b46af
--- /dev/null
+++ b/dev-lang/dafny-bin/dafny-bin-4.4.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Verification-aware programming language"
+HOMEPAGE="https://dafny.org/
+ https://github.com/dafny-lang/dafny/"
+SRC_URI="https://github.com/dafny-lang/dafny/releases/download/v${PV}/dafny-${PV}-x64-ubuntu-20.04.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+REQUIRED_USE="elibc_glibc"
+
+RDEPEND="
+ !dev-lang/dafny
+ dev-libs/userspace-rcu
+ dev-util/lttng-ust:0/2.12
+ sci-mathematics/z3
+"
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}/dafny"
+QA_PREBUILT="*"
+
+src_prepare() {
+ default
+
+ # Remove bundled z3.
+ # NOTICE: New versions do not need the bundled one but older versions
+ # hardcoded the path relative to "dafny" binary.
+ # While bumping make sure to verify that system's "z3" is used
+ # by, for example, compiling/verifying a simple dafny program.
+ rm -r z3 || die
+}
+
+src_install() {
+ local dest=/opt/dafny
+
+ insinto ${dest}
+ # Maybe too general, but this installation mode matched how it arrives.
+ insopts -m0755
+ doins "${S}"/*
+
+ local bin
+ for bin in DafnyServer dafny ; do
+ dosym ../../${dest}/${bin} /usr/bin/${bin}
+ done
+
+ # Make "dafny-server" clients happy.
+ dosym ../../${dest}/DafnyServer /usr/bin/dafny-server
+}