summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-02-24 23:08:53 +0000
committerJames Le Cuirot <chewi@gentoo.org>2024-02-24 23:08:53 +0000
commitff8d9f188ee04d7cb0737e55b6e917cf569679de (patch)
treeaabaa102a4c1d42590acbad05ff93df19be23fa7
parentsys-kernel/genkernel: fix PYTHON_COMPAT (diff)
downloadgentoo-ff8d9f188ee04d7cb0737e55b6e917cf569679de.tar.gz
gentoo-ff8d9f188ee04d7cb0737e55b6e917cf569679de.tar.bz2
gentoo-ff8d9f188ee04d7cb0737e55b6e917cf569679de.zip
app-crypt/gnupg: Fix cross-compiling by using gpgrt-config
It appears to be a reimplementation of pkg-config in Bash. It even uses the SYSROOT properly without setting any environment variables, seemingly by basing paths on where it was executed from. As such, using the build host's gpgrt-config doesn't work. npth 1.7 is needed to cross-compile successfully but older versions work for native builds. Closes: https://bugs.gentoo.org/914711 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--app-crypt/gnupg/gnupg-2.4.4-r1.ebuild6
1 files changed, 1 insertions, 5 deletions
diff --git a/app-crypt/gnupg/gnupg-2.4.4-r1.ebuild b/app-crypt/gnupg/gnupg-2.4.4-r1.ebuild
index 768489c6bf9f..1bbfa46c8115 100644
--- a/app-crypt/gnupg/gnupg-2.4.4-r1.ebuild
+++ b/app-crypt/gnupg/gnupg-2.4.4-r1.ebuild
@@ -132,11 +132,7 @@ my_src_configure() {
--enable-large-secmem
CC_FOR_BUILD="$(tc-getBUILD_CC)"
- GPG_ERROR_CONFIG="${ESYSROOT}/usr/bin/${CHOST}-gpg-error-config"
- KSBA_CONFIG="${ESYSROOT}/usr/bin/ksba-config"
- LIBASSUAN_CONFIG="${ESYSROOT}/usr/bin/libassuan-config"
- LIBGCRYPT_CONFIG="${ESYSROOT}/usr/bin/${CHOST}-libgcrypt-config"
- NPTH_CONFIG="${ESYSROOT}/usr/bin/npth-config"
+ ac_cv_path_GPGRT_CONFIG="${ESYSROOT}/usr/bin/${CHOST}-gpgrt-config"
$("${S}/configure" --help | grep -o -- '--without-.*-prefix')
)