summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-26 17:17:23 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-07 12:36:44 +0100
commit9e9a0954e4edcfcf7fb9b91d7fdb913968daba46 (patch)
treeac20620c407ea05e793274218172adf3d2c35e31 /app-admin/clsync
parentmeson.eclass: Pass -Db_lto=false globally (diff)
downloadgentoo-9e9a0954e4edcfcf7fb9b91d7fdb913968daba46.tar.gz
gentoo-9e9a0954e4edcfcf7fb9b91d7fdb913968daba46.tar.bz2
gentoo-9e9a0954e4edcfcf7fb9b91d7fdb913968daba46.zip
app-admin/clsync: [QA] Remove invalid USE=lto
USE=lto in this package only appends -flto flag. This is not a valid use of the USE flag, as lto in Gentoo is enabled via setting flags manually. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin/clsync')
-rw-r--r--app-admin/clsync/clsync-0.4.5.ebuild7
-rw-r--r--app-admin/clsync/clsync-9999.ebuild7
2 files changed, 8 insertions, 6 deletions
diff --git a/app-admin/clsync/clsync-0.4.5.ebuild b/app-admin/clsync/clsync-0.4.5.ebuild
index 239047ab2b24..a8a38fe6d81f 100644
--- a/app-admin/clsync/clsync-0.4.5.ebuild
+++ b/app-admin/clsync/clsync-0.4.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,7 +19,7 @@ LICENSE="GPL-3+"
SLOT="0"
IUSE="apidoc +caps +clsync cluster control-socket cgroups doc debug
examples extra-debug extra-hardened gio +hardened +highload-locks
-+inotify +lto mhash namespaces seccomp socket-library static-libs"
++inotify mhash namespaces seccomp socket-library static-libs"
REQUIRED_USE="
|| ( clsync socket-library )
@@ -65,7 +65,9 @@ src_configure() {
use debug && debug_level=1
use extra-debug && debug_level=2
+ # --enable-lto just appends -flto
econf \
+ --disable-lto \
--enable-debug=${debug_level} \
--enable-paranoid=${harden_level} \
--without-bsm \
@@ -75,7 +77,6 @@ src_configure() {
$(use_enable cluster) \
$(use_enable control-socket socket) \
$(use_enable highload-locks) \
- $(use_enable lto) \
$(use_enable namespaces unshare) \
$(use_enable seccomp) \
$(use_enable socket-library) \
diff --git a/app-admin/clsync/clsync-9999.ebuild b/app-admin/clsync/clsync-9999.ebuild
index 3c91bb41d6fe..8c8429b74c63 100644
--- a/app-admin/clsync/clsync-9999.ebuild
+++ b/app-admin/clsync/clsync-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,7 +19,7 @@ LICENSE="GPL-3+"
SLOT="0"
IUSE="apidoc +caps +clsync cluster control-socket cgroups doc debug
examples extra-debug extra-hardened gio +hardened +highload-locks
-+inotify +lto mhash namespaces seccomp socket-library static-libs"
++inotify mhash namespaces seccomp socket-library static-libs"
REQUIRED_USE="
|| ( clsync socket-library )
@@ -65,7 +65,9 @@ src_configure() {
use debug && debug_level=1
use extra-debug && debug_level=2
+ # --enable-lto just appends -flto
econf \
+ --disable-lto \
--enable-debug=${debug_level} \
--enable-paranoid=${harden_level} \
--without-bsm \
@@ -75,7 +77,6 @@ src_configure() {
$(use_enable cluster) \
$(use_enable control-socket socket) \
$(use_enable highload-locks) \
- $(use_enable lto) \
$(use_enable namespaces unshare) \
$(use_enable seccomp) \
$(use_enable socket-library) \