summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/consolehm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/consolehm')
-rw-r--r--app-admin/consolehm/Manifest1
-rw-r--r--app-admin/consolehm/consolehm-1.31.ebuild46
-rw-r--r--app-admin/consolehm/files/consolehm-gcc4.patch10
-rw-r--r--app-admin/consolehm/metadata.xml5
4 files changed, 62 insertions, 0 deletions
diff --git a/app-admin/consolehm/Manifest b/app-admin/consolehm/Manifest
new file mode 100644
index 000000000000..79b26d427325
--- /dev/null
+++ b/app-admin/consolehm/Manifest
@@ -0,0 +1 @@
+DIST consolehm-1.31.tar.gz 21615 SHA256 121bdc1f50f06e7a751bf1aee9d3d7d36415b234a524af6b6f626dcf5b9d5ef6 SHA512 595a5808bf85b878254e10fbe9a7beccffb4e5a35e03fe9fbea710963733fb4d6afe6fe6b70b30fa2b4fd565ed4ac1ffcca624b6717cc3b6d900960e7e6001f8 WHIRLPOOL 81d90880049acb338d4e94b00afcf88f7b897b60377dcb3a1844785d456483cdf1e079692aca387168246b5e945936feaa54759f3df4aaf5d67bedc15ddac577
diff --git a/app-admin/consolehm/consolehm-1.31.ebuild b/app-admin/consolehm/consolehm-1.31.ebuild
new file mode 100644
index 000000000000..ade0fa3a3011
--- /dev/null
+++ b/app-admin/consolehm/consolehm-1.31.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Console based hardware monitor for FreeBSD"
+HOMEPAGE="ftp://ftp.freebsd.org/pub/FreeBSD/ports/local-distfiles/fenner/"
+SRC_URI="ftp://ftp.freebsd.org/pub/FreeBSD/ports/local-distfiles/fenner/${P}.tar.gz"
+LICENSE="BSD-2"
+SLOT="0"
+
+KEYWORDS="~x86-fbsd"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${PN}-gcc4.patch || die "patch failed"
+ export CHMS="${S}/consolehm"
+ # The only 'SMBus' smb.h i've found is in a different place:
+ cd "${S}/consolehm"
+ sed -i.orig -e 's:machine/smb.h:dev/smbus/smb.h:g' \
+ configure.in \
+ configure \
+ chm.h || die "sed failed."
+}
+
+src_compile() {
+ cd "${S}/consolehm"
+ econf || die "econf failed"
+ MAKE=make emake || die "emake failed"
+}
+
+src_install() {
+ dobin "${S}/consolehm/chm"
+ doman "${S}/consolehm/chm.8"
+ dodoc "${S}"/CHANGELOG
+ dodoc "${S}"/README
+ dodoc "${S}"/TODO
+}
diff --git a/app-admin/consolehm/files/consolehm-gcc4.patch b/app-admin/consolehm/files/consolehm-gcc4.patch
new file mode 100644
index 000000000000..85f677a29cbf
--- /dev/null
+++ b/app-admin/consolehm/files/consolehm-gcc4.patch
@@ -0,0 +1,10 @@
+--- consolehm/consolehm/chm.c.orig 2000-12-23 03:51:45 -0300
++++ consolehm/consolehm/chm.c 2007-01-12 11:18:27 -0300
+@@ -165,6 +165,7 @@
+ printf("Delay: %d microseconds. \n\n",delay);
+ break;
+ default:
++ ;;
+ }
+
+ file_handle = OpenIO();
diff --git a/app-admin/consolehm/metadata.xml b/app-admin/consolehm/metadata.xml
new file mode 100644
index 000000000000..ecedda4aa2cc
--- /dev/null
+++ b/app-admin/consolehm/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>bsd</herd>
+</pkgmetadata>