summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/fetchlog
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/fetchlog')
-rw-r--r--app-admin/fetchlog/Manifest2
-rw-r--r--app-admin/fetchlog/fetchlog-1.0.ebuild40
-rw-r--r--app-admin/fetchlog/fetchlog-1.4.ebuild41
-rw-r--r--app-admin/fetchlog/metadata.xml10
4 files changed, 93 insertions, 0 deletions
diff --git a/app-admin/fetchlog/Manifest b/app-admin/fetchlog/Manifest
new file mode 100644
index 000000000000..e86c712f7d24
--- /dev/null
+++ b/app-admin/fetchlog/Manifest
@@ -0,0 +1,2 @@
+DIST fetchlog-1.0.tar.gz 24016 SHA256 eba8150015cf43ebd41c8d8f8eaa598967ceafcd288a65ea1da4f21aa9fe3f79 SHA512 66a7a456ebb5353171b2f53071a73cccd66d42dafc2740bafd7c9db860f68176dffe10e556fde52048f2b198c2eaf8299d1fd6094726f7a003987b5ce0be7415 WHIRLPOOL 6197e06024b4228f29ff9c35ef26bd81352c836ab33e003c479482e270d54f79526e515a13f93ba1983c9e538aa96704e45cdd44cec530e28bc724a9caa9e915
+DIST fetchlog-1.4.tar.gz 32393 SHA256 2017cba285b4167fb9f148b4509d7463402820e4e7a04865cec0fe887bd5e13a SHA512 51590c0cdfa8f4a15fcb4a436375d960c25f35d84558ab46def58f83c97da30caee449eea7c62c539da786a613c2b1e51dbc223d70d56c21daad6e9faf8a51ad WHIRLPOOL b6ed75be2c70a361ea569030386e6a14519f3102950cf23a291689a37d69dc49a9f3f2698b7ff5d640f29450496e37315772ff18946b1b7e0d374cba0b7b41f4
diff --git a/app-admin/fetchlog/fetchlog-1.0.ebuild b/app-admin/fetchlog/fetchlog-1.0.ebuild
new file mode 100644
index 000000000000..140838c1260b
--- /dev/null
+++ b/app-admin/fetchlog/fetchlog-1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="Displays the last new messages of a logfile"
+HOMEPAGE="http://fetchlog.sourceforge.net/"
+SRC_URI="mirror://sourceforge/fetchlog/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~ppc64"
+
+IUSE="snmp"
+
+RDEPEND="snmp? (
+ >=dev-perl/Net-SNMP-4.0.1-r2
+ >=net-analyzer/net-snmp-5.0.6
+ )"
+
+pkg_preinst() {
+ elog
+ elog "This utility can be used together with Nagios"
+ elog "To make use of these features you need to"
+ elog "install net-analyzer/nagios."
+ elog "This feature depends on SNMP, so make use you"
+ elog "have 'snmp' in your USE flags"
+ elog
+}
+
+src_compile() {
+ # Links the .c file straight to the binary
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${LDFLAGS}" || die
+}
+
+src_install() {
+ dodoc CHANGES README*
+ dobin fetchlog
+ doman fetchlog.1
+}
diff --git a/app-admin/fetchlog/fetchlog-1.4.ebuild b/app-admin/fetchlog/fetchlog-1.4.ebuild
new file mode 100644
index 000000000000..7bf7b9bfd25b
--- /dev/null
+++ b/app-admin/fetchlog/fetchlog-1.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="Displays the last new messages of a logfile"
+HOMEPAGE="http://fetchlog.sourceforge.net/"
+SRC_URI="mirror://sourceforge/fetchlog/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc64"
+
+IUSE="snmp"
+
+RDEPEND="snmp? (
+ >=dev-perl/Net-SNMP-4.0.1-r2
+ >=net-analyzer/net-snmp-5.0.6
+ )"
+
+pkg_preinst() {
+ elog
+ elog "This utility can be used together with Nagios"
+ elog "To make use of these features you need to"
+ elog "install net-analyzer/nagios."
+ elog "This feature depends on SNMP, so make use you"
+ elog "have 'snmp' in your USE flags"
+ elog
+}
+
+src_compile() {
+ # Links the .c file straight to the binary
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${LDFLAGS}" || die
+}
+
+src_install() {
+ dodoc CHANGES README*
+ dodoc *cfg*
+ dobin fetchlog
+ doman fetchlog.1
+}
diff --git a/app-admin/fetchlog/metadata.xml b/app-admin/fetchlog/metadata.xml
new file mode 100644
index 000000000000..a12c82df6025
--- /dev/null
+++ b/app-admin/fetchlog/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">fetchlog</remote-id>
+ </upstream>
+</pkgmetadata>