summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2017-11-16 14:59:50 +0100
committerAmy Liffey <amynka@gentoo.org>2017-11-16 16:12:18 +0100
commitdb470559557ba7d2a505c41908ba936cd3802c87 (patch)
tree41e8f62db5eed21dc59be5e5b5f43f0fce9851b1 /app-admin/logstash-bin
parentapp-admin/filebeat: drop old (diff)
downloadgentoo-db470559557ba7d2a505c41908ba936cd3802c87.tar.gz
gentoo-db470559557ba7d2a505c41908ba936cd3802c87.tar.bz2
gentoo-db470559557ba7d2a505c41908ba936cd3802c87.zip
app-admin/logstash-bin: bump to 5.6.4
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'app-admin/logstash-bin')
-rw-r--r--app-admin/logstash-bin/Manifest1
-rw-r--r--app-admin/logstash-bin/logstash-bin-5.6.4.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/app-admin/logstash-bin/Manifest b/app-admin/logstash-bin/Manifest
index 435491bc71c1..8d2f0e1741ac 100644
--- a/app-admin/logstash-bin/Manifest
+++ b/app-admin/logstash-bin/Manifest
@@ -1,2 +1,3 @@
DIST logstash-5.5.3.zip 99551442 SHA256 f81ff55feb21ff4edd4283938ac8362c2906d98f9427d8660dab8465e08f0da9 SHA512 a4328ad0b8192b7c5aaed155d608d9db6adeaefd640e461ef4467daa1a28a2ae25d6b2b1adcf47c5dd82b66fc1adbf8ba5f3eabcf7e69dd8719a5860795877aa WHIRLPOOL d3482df4a7729f6b34973816e39315c69254a641e9811131d7d5e12ede54003a326c5773e799ee471dda01a6113762919ea81ab56ede62d29221f63ed5a7f8c7
DIST logstash-5.6.3.zip 109744226 SHA256 8fbe9deebfe459a568634c78371e85985d7629442194f2c3b60dd43cd3a9f4e4 SHA512 2a1e5d24b4f4b8e96a43a9ec278b94dfd681eba64a19c6341140a15014d24702b832da322e109dcf2100f980d93e07acb37466e1e2a725494ef1be5c2ac857c8 WHIRLPOOL 4d8b868b7566beff06bfac32090ec07b4dc830fe88abb1c249e424e9a121fb59cce93d1c51f9bf05223c6b7c4003f38b61e3405840c9a1a0b29bc79030f0af62
+DIST logstash-5.6.4.zip 109819435 SHA256 8809cee0b4199eafd5e3094243929d24b0d22c9d2fcaa473cb7031207d079ca8 SHA512 5382671758d905bbd89f9e05eff9ffcf4a3bbc4fca6f06844647c31df3f50198c297daa0151915c9ef1f0cd741ccb9fb12a7fa13cdc429463d92783c92624717 WHIRLPOOL e1d4cea766025564cb12720528ce0819b3787fb4ffc1901593786d79195ea1584834b70d0406d4b39dfcc236c9239af9e63b37e497c9fc7a79899a4a5f62b429
diff --git a/app-admin/logstash-bin/logstash-bin-5.6.4.ebuild b/app-admin/logstash-bin/logstash-bin-5.6.4.ebuild
new file mode 100644
index 000000000000..f5c2a9c0a255
--- /dev/null
+++ b/app-admin/logstash-bin/logstash-bin-5.6.4.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit java-pkg-2 user
+
+MY_PN="${PN%-bin}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Tool for managing events and logs"
+HOMEPAGE="https://www.elastic.co/products/logstash"
+SRC_URI="https://artifacts.elastic.co/downloads/${MY_PN}/${MY_P}.zip"
+
+# source: LICENSE.txt and NOTICE.txt
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="strip"
+QA_PREBUILT="opt/logstash/vendor/jruby/lib/jni/*/libjffi*.so"
+
+RDEPEND="virtual/jre:1.8"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup ${MY_PN}
+ enewuser ${MY_PN} -1 -1 /var/lib/${MY_PN} ${MY_PN}
+}
+
+src_install() {
+ keepdir /etc/"${MY_PN}"/{conf.d,patterns,plugins}
+ keepdir "/var/lib/${MY_PN}"
+ keepdir "/var/log/${MY_PN}"
+
+ insinto "/usr/share/${MY_PN}"
+ newins "${FILESDIR}/agent.conf.sample" agent.conf
+
+ rm -v config/startup.options || die
+ insinto /etc/${MY_PN}
+ doins config/*
+ rm -rv config data || die
+
+ insinto "/opt/${MY_PN}"
+ doins -r .
+ fperms 0755 "/opt/${MY_PN}/bin/${MY_PN}" "/opt/${MY_PN}/vendor/jruby/bin/jruby" "/opt/${MY_PN}/bin/logstash-plugin"
+
+ newconfd "${FILESDIR}/${MY_PN}.confd-r1" "${MY_PN}"
+ newinitd "${FILESDIR}/${MY_PN}.initd-r1" "${MY_PN}"
+
+ insinto /usr/share/eselect/modules
+ doins "${FILESDIR}"/logstash-plugin.eselect
+}
+
+pkg_postinst() {
+ ewarn "The default pidfile directory has been changed from /run/logstash to /run."
+ ewarn "Please ensure any running logstash processes are shut down cleanly."
+ ewarn
+ ewarn "The default data directory has been moved from /opt/logstash/data to"
+ ewarn "/var/lib/logstash/data. Please check and move its contents as necessary."
+ ewarn
+ ewarn "Self installed plugins are removed during Logstash upgrades (Bug #622602)"
+ ewarn "Install the plugins via eselect module that will automatically re-install"
+ ewarn "all self installed plugins after Logstash upgrades."
+ einfo
+ einfo "Installing plugins:"
+ einfo "eselect logstash-plugin install logstash-output-gelf"
+ einfo
+
+ einfo "Reinstalling self installed plugins (installed via eselect module):"
+ eselect logstash-plugin reinstall
+
+ einfo
+ einfo "Sample configuration:"
+ einfo "${EROOT%/}/usr/share/${MY_PN}"
+}