summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUltrabug <ultrabug@gentoo.org>2016-01-20 13:47:41 +0100
committerUltrabug <ultrabug@gentoo.org>2016-01-20 13:47:41 +0100
commit5f156b055166464825a020e5724ab9352171cb5a (patch)
treee263d30117d9827d858758a99a6dac476c9a8d18 /app-admin/mongo-tools
parentdev-db/mongodb: version bump, fix #572166 #572258 (diff)
downloadgentoo-5f156b055166464825a020e5724ab9352171cb5a.tar.gz
gentoo-5f156b055166464825a020e5724ab9352171cb5a.tar.bz2
gentoo-5f156b055166464825a020e5724ab9352171cb5a.zip
dev-db/mongodb: drop old
Diffstat (limited to 'app-admin/mongo-tools')
-rw-r--r--app-admin/mongo-tools/mongo-tools-3.2.0.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/app-admin/mongo-tools/mongo-tools-3.2.0.ebuild b/app-admin/mongo-tools/mongo-tools-3.2.0.ebuild
deleted file mode 100644
index 658782fe250e..000000000000
--- a/app-admin/mongo-tools/mongo-tools-3.2.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils
-
-MY_PV=${PV/_rc/-rc}
-MY_P=${PN}-r${MY_PV}
-
-DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
-HOMEPAGE="http://www.mongodb.org"
-SRC_URI="https://github.com/mongodb/mongo-tools/archive/r${MY_PV}.tar.gz -> mongo-tools-${MY_PV}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="sasl ssl"
-
-# Maintainer note:
-# openssl DEPEND constraint, see:
-# https://github.com/mongodb/mongo-tools/issues/11
-
-RDEPEND="!<dev-db/mongodb-3.0.0"
-DEPEND="${RDEPEND}
- dev-lang/go:=
- sasl? ( dev-libs/cyrus-sasl )
- ssl? ( dev-libs/openssl )"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-3.0.0-build.patch"
-}
-
-src_compile() {
- local myconf
-
- if use sasl; then
- myconf="${myconf} sasl"
- fi
-
- if use ssl; then
- myconf="${myconf} ssl"
- fi
-
- ./build.sh ${myconf}
-}
-
-src_install() {
- dobin bin/*
-}