summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2019-05-13 16:40:37 +0200
committerAgostino Sarubbo <ago@gentoo.org>2019-05-13 16:40:37 +0200
commit511a251f2b1baf7ea16862ef776cfdd14ad16f4c (patch)
treec806fc9ebb7b404abce6bf5b7b198d5fe391d4d4 /app-admin
parentdev-python/dnspython: Version bump to 1.16.0 (diff)
downloadgentoo-511a251f2b1baf7ea16862ef776cfdd14ad16f4c.tar.gz
gentoo-511a251f2b1baf7ea16862ef776cfdd14ad16f4c.tar.bz2
gentoo-511a251f2b1baf7ea16862ef776cfdd14ad16f4c.zip
app-admin/ansible: revision bump to really install rc3
Signed-off-by: Agostino Sarubbo <ago@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ansible/Manifest1
-rw-r--r--app-admin/ansible/ansible-2.8.0_rc3-r1.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/app-admin/ansible/Manifest b/app-admin/ansible/Manifest
index 96d2601fca34..b4b2181181ca 100644
--- a/app-admin/ansible/Manifest
+++ b/app-admin/ansible/Manifest
@@ -3,3 +3,4 @@ DIST ansible-2.6.16.tar.gz 10738431 BLAKE2B b801eb524f631950c385f7a949bdeae288e9
DIST ansible-2.7.10.tar.gz 11844278 BLAKE2B c847b642ebe4cbc2194538a0b194cd5c0bb82e0ba2a6da2e272670c75596b9793e028d067ddb37000c07f2c2427b5b99248b16c544daed4976c0210b601d3c97 SHA512 4d58ef080c8ee02ef36eb3116ec89e4542b5b4042262953b2001081601fe1066237191cce5e647f354efa9e1933cf5010519d049e678a90e8ca08620cd1788a5
DIST ansible-2.7.9.tar.gz 11830476 BLAKE2B 7688ce9f74b0ab1fafd0e31dce90d995a9d8ca90bbe436f2d4ee9d005069b6e1b2c4dd679c2430a6873233da54ae06d3ebf08736681ec2e59e5b3ddafa6bb1e2 SHA512 4d39c7d4eb97264ce8f92812fb986b24af0c663efa6d8cd1d9a4cb25731d55e7518e503c04764e62d0458916b601baaa7acc623f9f83ce8b93e7f22900e29a53
DIST ansible-2.8.0rc2.tar.gz 14281093 BLAKE2B c829ba6b46f5be76151fef442ed6fde23a78390743a9e5381730bbb26780d00d75e6212c2cb424bb58faa77df48683a33c967a55ed10bfa05fcc897bc4494161 SHA512 346542ed1b3f7a9cbc1045e1ba2fa72659c3af2b40797efc24a50e8e23d437ccd7a7f9d984e870c95a53301809e88203c2f9226f3c79cca51b28134fae609a8d
+DIST ansible-2.8.0rc3.tar.gz 14280884 BLAKE2B ccce66a66dd4567686b936b6bc7578b0bbbf33f4d315e4606c5dc1c317801b0e41a94263a6c94b6d17e2a5c3a51d7378bff2120255bfa597156bbf5254ad8da9 SHA512 bb9e2a885d2f19ed8b477d65bde636d7d3fe1540b1a5c6b84e5ce38d35973a68bfe7ffd8b43a8daa5b82bedcbbc4b3392eeeefb264b98cadb03b6f8fce2e4bec
diff --git a/app-admin/ansible/ansible-2.8.0_rc3-r1.ebuild b/app-admin/ansible/ansible-2.8.0_rc3-r1.ebuild
new file mode 100644
index 000000000000..b02d7718efec
--- /dev/null
+++ b/app-admin/ansible/ansible-2.8.0_rc3-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://ansible.com/"
+# don't forget to fix also ${S} in the next bump
+SRC_URI="https://releases.ansible.com/${PN}/${PN}-2.8.0rc3.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~x64-macos"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+S="${WORKDIR}/ansible-2.8.0rc3"
+
+python_compile_all() {
+ if use doc; then
+ cd docs/docsite || die
+ export CPUS=4
+ emake -f Makefile.sphinx html
+ fi
+}
+
+python_prepare_all() {
+ rm -fv MANIFEST.in || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
+ distutils-r1_python_install_all
+
+ dodoc -r examples
+}